3 Xbox 360 TPS bugs

Xbox 360
BL:TPS
Skill Point Glitch

I have a skill point glitch for whenever I join a co-op game, it just resets my skill points. Usually it says I have 39 skill points to spend, but sometimes it resets them all so I have 48 to spend. It really bugs me, especially on my level 50 character with all legendaries. At first I just left the game without saving, and that worked. After a while that failed. One time it even said it was corrupted.

Xbox 360
BL:TPS
Losing Heads Glitch

On my character, they all just lost some of their heads for their characters. No big deal, I just can’t get Champion of Eleseer again, or the trash can one. Forgot the name of that. All the rest of the character lost all of their heads completely. None said they were corrupted, though.

Xbox 360
BL:TPS
Mass Corruption

For some reason, on my second Memory Unit and on my USB Storage Device, every single bit got corrupted. No characters or anything. Everything was just corrupted. I think it was because I haven’t played in a while.

The first two are common bugs that have plagued the game (and BL2 as well) since launch. Unfortunately, they’re intermittent, don’t affect every one to anywhere near the same extent, and therefore really hard to pin down a cause. At this point, I doubt they’re going to get fixed. My only advice to minimise the risk is:

  • Make sure you always save and quit out of co-op sessions before the host does
  • Never hit that option if you see the “saving” icon on your screen (the game shouldn’t let you access the menu at that time, but stuff happens)
  • When you’re joining a game, don’t commit at the character confirmation page if the host is in a menu, a vendor, or in intense combat (tricky to know some of these things, but you can usually tell from the background sound - or lack of it)

I’ve had this happen to me once with a USB key, where the entire encrypted XBox partition got corrupted. I think that happened when I tried to access the drive without realising I wasn’t yet signed in to my profile. Since then, I’ve always been careful to insert and remove USB keys while I’m still signed in.

The other thing that can corrupt the files for either TPS or BL2 is if you pull the key (or turn the system off) while it’s still writing data. In TPS in particular, there’s a lot of player data in a file called “Profile Data” inside the game folder. This contains your BAR stuff, bank and stash contents, etc. (This is why you can have valid save files but still lose heads etc - it means your profile data file got hosed.) Worst thing that can happen is a power outage or glitch while the 360 is saving (also accidentally powering everything off while it’s still saving, but that’s avoidable.)

2 Likes

In my opinion, if they are common bugs, they need to be fixed. Gearbox really needs to takes care of their games, especially The Pre-Sequel. That game was bugged from the start.

xbox 360: borderlands the pre-sequel vanishing skins: so, i signed in, joined a game with my bro, just now actually, and all my skins were missing. all my heads, my zoomy skins, my character skins, gone. POOF! no evidence that they were ever there. this is seemingly a common problem, and it is mind boggling that gearbox hasn’t fixed this issue. Please work on this, i would HATE to see other people go through this torture.

Finally picked this game back up and loaded up my lvl 49 fr4g-tp unit ( who hasn’t beaten the sentinel again) and am currently standing beside SH4D0W-TP in the cortex during End of Line. I haven’t beaten his minions yet… I’m stuck in his box with the h- source.

Are you still stuck there? I could poke around my 360 save files and see if there’s one you could join to get past that and complete the mission.

1 Like

I’m no longer stuck there. I managed to use Gibbed (Although i hate using
it) to change my location.