Achievements on Steam are bugged

So I came from epic and read that I needed to do a fresh playthrough of the game to get achievements. No problems there, thought it would be fun to do. I just finished beating the game finding all locations, crew challenges, red chests, and doing all side missions and these achievements did not pop when their respective requirements were met:

  • Tales From the Eridian Slab
  • Slaughterhouse 3
  • A Hundred Names For Sand
  • Swamped
  • Master of All You Survey
  • Getting a Little On The Side
  • 100-Proof
  • Got Big Game
  • Zer0ed In
  • A Proper Hand-Off
  • Scovillain

Yes I know what is needed to complete them and no I am not missing anything. I have spent the past two days making sure I did have every little location or target or eridian slab. Would love an update on this that isn’t “Play through the game again and see if it works.” Also keep in mind if an achievement is not listed here (City Slicker for example) that means that it did pop (City Slicker did thankfully).

Please let me know.

6 Likes

First one you can try ‘reading’ the slab in Tannis’ lab a few times - there seems to be some weird discrepancy on that (this fix works on XB1, possibly also PS4).

The location ones are a pain - again, a well-known issue that’s probably not high on the priority fix list since it only affects trophy completion. There are several locations where you have to hit the exact right spot to get the location counted for trophy completion - again, I suggest you check the XB1/PS4 sections where folks discuss the same trophy issue for suggestions.

I don’t remember off the top of my head all the others, but I do know you have to complete the ones related to the crew challenges on the same character in the same play-through. I’ll assume you’ve already done that, but maybe check against the interactive BL3 map to make absolutely sure you didn’t miss one.

But right now there is a bug/glitch that resets ALL Your locations everytime You leave the game, so You would need to do it in a one go. Very annoying especially that if You miss one You need to do it from the beggining.

Tried spamming the eridian slab and no dice. The super annoying ones are the fact that hammerlock hunts, zero targets and all side missions ones didn’t pop. I had heard about the locations just was hoping it would’ve been fixed by now.

That is super annoying. I just looked at the global achievement list and find it funny how Master of all you Survey has been achieved by more people than any of the planet specific ones, so that makes me even more wary as that doesn’t make any sense

1 Like

It doesn’t - that specific challenge popped for me before I had any of the planet specific ones. It seems to use a different counter from the planets and challenge totals.

NONE of the steam achievements are unlocking for me, nothing, not even the story ones… this is ridiculous … I’m playing with two friends and their achievements aren’t unlocking either… Has anyone heard anything about this being fixed?

Yup, same issue. As an aside I’ve also got “My Name Is Earl” bugged, stuck on 5/20 even though I’ve purchased 25+ items from Earl.

I have the same issue. All of the location-based achievements are broken (City Slicker, etc) as is the Eridian Slab achievement. I was able to get City Slicker by walking to every single location in a single playthrough, but that is an exceptionally time consuming method and very annoying. It seems as though it’s tied to the fact that if you return to Sanctuary or quit the game, the backend log of all the places you’ve visited is erased. So every time you load up the game and go somewhere, it says you’ve discovered that area the first time you visit it.

I also tried to do the Tannis Eridian Slab trick to get the achievement, but no dice. The first time I went back, I was able to inspect it and read the writing, but it didn’t give the achievement. Now when I go back and inspect, the audio prompts are all about how I can’t read it.

I know these are low on the priority list, but it would be nice to see them fixed. Some of us like getting achievements, especially on our favorite games.

No achievements are working for me.

I just killed the Debt Collector and did not get the achievement “Who Collects the Collector?”.
(The Debt Collector Mk II, not mistaking it for the other possible spawns).

There is nothing tricking about that one. No specific place you must stand, no single play through issues, and no clicking tablets in Sanctuary.

Last week I did everything to get “Master of all you Survey” (the locations one), “Getting a Little on the Side” (all the side missions), and “Tales from the Eridian Slab” (Sanctuary tablet stopped doing anything). I even did it all again on a new character hoping that would help. But nothing.

I decided to go get the Debt Collector just so I could get an achievement fix, but also nothing. I wish knew a week ago, what I know now.

For the record, my last achievement was on May 7th.

I’m hoping the next patch will resolve it. My last achievement was the ‘Older Than the Trees’ on May 18. Going through the Steam achievements list; since then at least 10 that should have fired - base game and DLC - that have not. Fingers crossed.

I’m level 34 and not a single achievement has unlocked so far. I’ve got the Deluxe Edition, some people seem to believe it could be related to this.

My steam achievements have also been disabled since May 18th. Any updates on when they will be fixed? Didn’t see any mention of this in the June 11th patchnotes.

Yup, mine stopped late April. Just tested this am, tipped Moxxi enough to get two weapons sent to me from her and still the achievement is 0/1

I’d submit a bug report to 2k but I’d prolly loose-it when they tell me to re-install the game or some other 1st level bs reply.

Is there really that much of a disconnect between GBX and 2k where 2k is completely oblivious to current issues GBX is working on? Wouldn’t it be awesome if 2k read your bug report and replied back, “Thanks, we are aware and working to resolve”.

1 Like

Hi there,
Still got the same problem as the 11/15/2020. That really sucks and i think that i’ll not do them again for a long time, 82.2 hours in game for now.

I did not get the basic games achievements :

  • Zer0ed in,
  • 100-Proof,
  • Slaughterhouse 3,
  • City Slicker,
  • A hundred names for sand,
  • Getting a little on the side.

As i saw, we can try to get the map achievements by doing all of them in one run so i’ll try that but i got no trick to complete all the others.

If anyone has a solution, i’ll be glad to hear about it.

1 Like

Just bumping this because I have the exact same problem with the achievements you listed here. You aren’t the only one.

For 100-Proof and Slaughterhouse 3 I tried doing all of them without quitting the game or going back to Sanctuary but that did not solve the issue for me.

I don’t make games so I wouldn’t know but achievement tracking seems like an easy fix as well. Really disappointing.

1 Like

That’s an easy fix, nothing hard to do, Gearbox should work for that, that’s all :wink:

26 days have passed, still bugged, gearbox plis :frowning_face:

i have the same problem
date 21.12.2020

pls fix

Still having the same issues with these achievements. would greatly appreciate a fix
14/01/2021