Anti-Aliasing not working

Like the title says, I’m having quite the trouble with the anti-aliasing

Tried to put the video settings to the max and it still looks like the anti-aliasing just don’t work at all, tried to force it with Nvidia Inspector and still nothing, game looks like this

This is the config I used in Nvidia Inspector also

And this are the video settings in the game

It is all maxed out and still looks bad

Anyone have an idea about how to fix this?

Btw I use a GTX 960