Background Hods


(Oni) #82

I am not sure here, because i newer used blender. But it looks to me you assigned image file into transparecy channel.
Hodor take information about image file from Diffuse channel.
Also importing tutorial.dae into 3ds max cause material error, beacuse it does not use transparent channels and the information about image files is lost.
Anyway your tutorial dae file says. You are using diffuse channel with multypli blend_mode.
It should be additive blend_mode i think.


(realshiftzero) #83

Indeed this option was set to “Multiply” and I set it to “Add” (couldn’t find additive but I think this is the same) but sadly I get the same result in-game…I’m going to dig this a little bit more. Thank you very much for your answer as it gave me a good direction to look for mistakes and I was starting to despair :acmaffirmative:

edit : Just noticed that the sphere on the right of the screen doens’t display accordingly to the video
I get this white sphere/circle instead of a textured one and I don’t get why, it looks like this


Still looking for the culprit atm


(ajlsunrise) #84

Just checking that you have a shaders.map file, that it exists?


(realshiftzero) #85

There is a “SHADERS.MAP” file in my hodor directory, here is the content of this folder

HodRepContent

It appears that this white effect only occured when I changed the blend type setting from “Multiply” to “Add”, but if I switch back, preview is corrupted anyway…
I’m totally navigating in a thick fog with this, I even downgraded my Blender version to 2.78C to be sure to match the video but no success so far.
I’ve been lurking on the Blender forums for the past few days as I was suspecting an incompatibily with my system but I didn’t find anything that could lead me to a solution :confused:
Anyway, thank you for your reply, if you know a way to summon @Sastrei or another Blender master, be my guest :smiley:


(Taiidan Republic Mod) #86

DISCLAIMER I have never made a background (yet, it is on my list of things to try at some point)…

If backgrounds are anything like ships and subsystems, you should rename your image in the box highlighted below as “IMG[tutorial_DIFF]_FMT[8888]” instead of “tutorial_DIFF.tga”:

Also, is format 8888 a thing? I always used DXT1 for ships…


(Sastrei) #87

8888 is uncompressed TGA iirc.

Not sure what you are doing wrong…can you post your .blend file?


(Taiidan Republic Mod) #88

You don’t think that is problem? From the hodor trace it looks like it isn’t generating the material…


(Sastrei) #89

@dom I don’t think so, because HODOR should only care about the texture datablock. The texture reference itself shouldn’t matter.


(realshiftzero) #90

At least I got this right when you state so at some point in the video

Sure, there it is


I only slightly modified the one you linked in this thread. This is the same but with “Phong” instead of “Crooktor” and “Add” for the blend_type instead of “Multiply”, then I renamed it “tutorial2”.

When I open this file, I get this white sphere in the material preview tab instantly, and I’m totally clueless right now. I hope you’ll have better eyes and logic than me ^^’
In any case, thanks for the assistance guys :smiley:


(Sastrei) #91

@realshiftzero make sure your tutorial_DIFF.tga file is right next to your tutorial_light.dae and open up tutorial_light.dae and make sure this section:

  <library_images>
    <image id="IMG[tutorial_DIFF]_FMT[8888]-image" name="IMG[tutorial_DIFF]_FMT[8888]">
      <init_from>//..\tutorial_DIFF.TGA</init_from>
  </image>

is changed to this:

  <library_images>
    <image id="IMG[tutorial_DIFF]_FMT[8888]-image" name="IMG[tutorial_DIFF]_FMT[8888]">
      <init_from>tutorial_DIFF.TGA</init_from>
  </image>

Give it a try and let us know if that works.


(realshiftzero) #92

Yes !! That was it !! Thank you so much for having taken the time to check the .dae file, I couldn’t have found this on my own

It’s beautiful and everything looks in place :smiley:
Next one will be done from scratch, and once I’ll get used to the process, I’ll try with planets as well

I guess my white sphere issue is related to Blender, maybe a driver problem…but as long as it doesn’t prevent me from making backgrounds, it’s ok
Again, big big thank you guys, you just saved my week over here :heart_eyes:

Now if you’ll excuse me, I have some backgrounds to make…

You rock guys ! :wink:

edit : and this is my first try on my own background

New background screenshots

I used the powerful “Space Maker”, linked by @Sastrei in another thread, to generate the nebula. Very very useful tool !

Edit : Use of the detail tag and added 2 more pictures


(Taiidan Republic Mod) #93

Nice! This is inspiring me to get into backgrounds. This is all I have done so far and it is just proof that I can do something…


(realshiftzero) #94

Hahahahaha !! Unlimited POWEEER !!!
(shouting lightning out of his hands)

Backgrounds screenshots - Test planet integration/ stormy clouds

Still, it’s not the right way to integrate planet and I still have to find the good settings to avoid stars from being displayed in front of Neptune. I think I can set stars parameters in one of the three lua files in the background directory.
For the cloudy sky, this is the same, stars are displayed through the storm and with some angles, you can clearly see the texture is joining with a black line (because right and left borders colors don’t match and it’s pretty ugly)
I’m still digging, but if you guys know some super settings that would do the job, I’m all ears !


(Taiidan Republic Mod) #95

I guess the simple answer would be not to have stars where the planet is…

However I made a planet one using the gearbox example and I used a random starfield, but there were no stars in front of it. How does you planet work? Is is a mesh, or part of the background image?

  • Part of the background image --> modify the star map to black out that area
  • A mesh --> the planet should appear in front of the stars

(realshiftzero) #96

Yes sadly, the planet is part of the background, I still don’t feel comfortable enough with bg to start something as complicated for now. That is why the planet is not that big, otherwise deformations appear. But I think you gave me the answer I was looking for, it is possible to black out the star map, now I just have to find how :thinking:

I was reading the “modding thread” in order to find a way to do something like that when I saw your reply. If you remember a good post explaining the process, feel free to share (and thx for being here again :wink: )


(Taiidan Republic Mod) #97

In your case I would do:

  1. use HODOR to get TGA files from an existing star HOD file.

  2. delete the stars near the planet in the TGA files

  3. use HODOR to pack the modified TGA files back into a new star HOD.

The process is here:

Have a go and let us know if you get stuck.


(realshiftzero) #98

For sure I will take some serious time to check this tomorrow, now I’m starting to get tired and I don’t want to make “stupid” mistakes because I lack of awareness. Once again, thank you for the heads up, I’ll let you know what it says after I try this very soon :slight_smile:

Edit : So I’m still failing miserably even after that I checked the starfields related post (can’t believe it was right under my nose as I was asking for a way to look :facepalm: ) …I can’t even get my hodor script to work :confused:
I only managed to create the two exportation folders, but they are empty. Hodor always send me this error back : Error - COSMIC_MESH isn’t a mesh HOD
I don’t get it for now, it looks like some pretty tough stuff to digest so I made this one out of frustration, but we can still see some unwanted stars where they are not supposed to be.

Mars background

I’ll give it another go later, I need to practice more hodor to fully understand what I’m doing.

EDIT 1/2/3 : I forgot half of what I wanted to say, I guess it’s time to sleep.

ps : @radar3301 Thank you, if you want I can drop a link with this background if you will to try it yourself :wink:


(ajlsunrise) #99

That is a pretty, purple background. I like.

The in-atmosphere background is pretty cool too, (if not completely out of place…)


(Taiidan Republic Mod) #100

Ok, have a go like this:

hodor file to export TGA files from an existing starfield HOD
= -$HWRM_BASE=C:\Program Files (x86)\Steam\steamapps
= -$COSMIC_MESH=[path]\realshiftzero_light.hod
= -$COSMIC_SRCSTAR=[path]\any_starfield.hod
= -$$COSMIC_DEFS=$[HWRM_BASE]\common\Homeworld\GBXTools\HODOR\STARS.DEF
= -$$COSMIC_OPTS=Mat=background Width=4096 Height=2048
= -$COSMIC_DSTRGB=[path]\realshiftzero_stars_RGB.TGA
= -$COSMIC_DSTTEX=[path]\realshiftzero_stars_Tex.TGA
= -do=cosmic
= -action=null
hodor file to create starfield HOD from TGA files
= -$HWRM_BASE=C:\Program Files (x86)\Steam\steamapps
= -$COSMIC_MESH=[path]\realshiftzero_light.hod
= -$COSMIC_SRCSTAR=[path]\any_starfield.hod
= -$COSMIC_DSTSTAR=[path]\any_starfield.hod
= -$$COSMIC_DEFS=$[HWRM_BASE]\common\Homeworld\GBXTools\HODOR\STARS.DEF
= -$$COSMIC_OPTS=Mat=background Width=4096 Height=2048
= -$COSMIC_SRCRGB=[path]\realshiftzero_modified_stars_RGB.TGA
= -$COSMIC_SRCTEX=[path]\realshiftzero_modified_stars_Tex.TGA
= -do=cosmic
= -action=null

COSMIC_MESH must be the “light” HOD and COSMIC_SRCSTAR must be a starfield HOD. Obviously COSMIC_DSTSTAR will be your output HOD, so you could make it whatever name you want. The example above would overwrite any_starfield.HOD.


(realshiftzero) #101

I just saved your scripts, I’ll have a look upon that tonight. I took a quick pick at those and I’d have a few questions though…

script I used

= -$COSMIC_MESH=neptune_light.HOD
= -$COSMIC_SRCSTAR=neptune.hod
= -$COSMIC_DSTSTAR=neptune_Out.hod
= -$$COSMIC_DEFS=C:\Program Files (x86)\Steam\steamapps\common\Homeworld\GBXTools\HODOR\STARS.DEF

= -$$COSMIC_OPTS=Mat=background Width=4096 Height=2048
#= -$$COSMIC_OPTS=Mesh=PRE_Space
#= -$$COSMIC_OPTS=Merge

= -$COSMIC_DSTRGB=neptune_DEST_Stars_RGB.TGA
= -$COSMIC_DSTTEX=neptune_DEST_Stars_Tex.TGA

#= -$COSMIC_SRCRGB=neptune_SRC_Stars_RGB.TGA
#= -$COSMIC_SRCTEX=neptune_SRC_Stars_Tex.TGA

= -do=cosmic
= -action=null

I wanted to try with one script I could edit according to my needs

As you see I actually use the right _light.HOD file, but as it is one I made with hodor, is it considered by the game as a “valid” one ? I think I read @BitVenom mentionned something like this in the starfields topic, and I have to admit that the meaning is still blurry for me

EDIT : I just checked and in fact, it was about “Star HOD” that @BitVenom was talking about, not the _light.HOD…everything is mixing up in my head…

Anyway, I’ll be back around later, thank you for trying :smiley:

…and what about your background ? it was promising… :stuck_out_tongue_winking_eye:

EDIT2 : ok so, I just tried to export tga files with your script, I don’t get any error this time but all I get is 2 big white images. This said, I can’t see any progress status in hodor. I press enter, hodor seems to react and then I get that DOS message “press a key to continue” just like the job has been done. But in my case, without the expected result.
I was wondering if this variable [path] had to be defined like [HWRM_BASE] or may I put the right path manually ? Does it make that much of a difference in one way or another ? I’m so not used with coding…