BIA 1&2 flickering purple textures


(armitom) #1

Hi
I recently decided to go back and play my favorite games.
Unfortunately i run into a problem which i had before on Windows 10 anniversary, i would run the game and the textures&objects were glitching out with weird colors making the game unplayble.

I fixed it with the guide (PCgamingwiki) by adding compatibility mode to winxp-sp3, and that was it, problem solved, that was a year ago on Win10 Anniversary Update

Now its back AGAIN, same Hard Drive, same Game installation with warzone mod, didn’t touch anything .

I have spend hours trying to fix it, forcing the game to run in 1 core, re-installing, trying different compatibility modes

I am furious, i am on the point of saying FU to WIN10 and go back to 7, this is not the first and probably wont be the last game that worked fine but some update messed it up.
It could also be a driver issue with AMD, this i haven’t tried since i have a lot of modern games installed and going back and forth with drivers isnt the most elegant solution

My Specs
Win10 Fall Creators Update
I5 4460
R9 390 8gb
16gb Ram

I know you guys wont be able offer much help, this is a small community, but any comment would be appreciated :frowning:


(armitom) #2

Well running it on Windowed mode fixes it (its always the last thing you think of)
Its not perfect

Apparently the creators update has done something to optimize full screen games, checking the box in the .exe properties doesn’t do anything
The first Splinter Cell has that problem too, i have to run it in windowed mode, before it was working fine.

Edit: And i removed the window pane around the game by using windowedborderlessgaming, useful little program.

Everything works fine-ish now, at least it seems too, annoying that win10 always messes up with games like that.


(Nick250ification) #3

Sigh… this was my most favorite game to ever play same with BIA Earned in Blood. worked perfectly fine on my Hp 2000 with the windows 8.1 update but now windows 10 is out… I cant play my favorite childhood game… I just see the games on my steam game collection collecting dust and me being forced to to play Brothers in arms Hell’s Highway… Such a sad moment for all us users who want to go back and play such fun games


(armitom) #4

Whats the problem? i got it running fine in W10 by adding “compatibility for WinXP SP3” and “-windowed” on the target line of the .exe, then using the program “borderless gaming” to make the game full screen.

Both BIA1&2 worked fine on my system with those fixes, finished both just a few weeks ago

I found most of the fixes on PCgamingwiki.


(LeYuno) #5

so I had this problem with post scriptum. fullscreen gave colored flickering (green in my case) and I have an nvidia card.

apparently it has something to do with the color range settings in the control panel of your card. After I changed some things in the nvidia control panel the problem was fixed. Check if you can’t find a fix online somewhere for yours.


(armitom) #6

As i mentioned in my post above, i did find a fix, i had to put the game on windowed mode by adding -windowed on the target line on the .exe properties, then use borderless to force the game to fullscreen.

I did play with the AMD control panels with settings like tesselation/shader cache etc for hours but nothing worked. Same with the color settings but nothing changed either

Only windowed mode fixes it, as i said before i think it has something to do with the windows 10 update they released last fall thats when the problem appeared, alongside the new “fullscreen optimizations” option they forced in ALL games.