.big troubles trying to edit (RESOLVED)

Hi folks so i played homeworld back in the day and just discovered the remastered edition. now i remember back in the day you could edit the .big files and i would like to do this again , i know the files r encrypted , i have found a decrypter and edit the files ( all i want is to add a few hit points to my ships) then i re big the file and copy it into the game directory. the game will launch but when i hit single player the progress bar goes half way then crashes out to windows giving an access violation . i have the purchased steam version , my pc is a quad core 3.2 8 gig of ram win 10 64bit . amd r7 card drivers up to date
please help dying to play

OK, my advice if you want to start editing the game’s files (we all started there), don’t bother putting the files in a .big again, that’s too much hassle for nothing. Just create, in \Data, a folder called ship and put the folder of the edited ships with the files you modified in \ship\

For example, if you edited the Hiigaran Mothership, create the folder ship in Data and hgn_mothership in ship so you have \Data\ship\hgn_mothership and then you put hgn_mothership.ship in that folder. After that, you go to \Bin\Release, make a shortcut to HomeworldRM.exe, and in the target parameter of the shortcut, you add -overridebigfile

Now, your shortcut will read the files you edited and you’ll be able to enjoy them properly. If, however, you replaced the original .big files with your edited ones and they crash, I’d highly recommend you to redownload them via Steam before doing anything else.

ill be trying this now… thanks ill let you know fingers crossed

so i unpacked the big changed one ship as a test created a folder in C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\Data… called ship i dropped my kus_mothership ship folder in there it has 6 files in it one of which is the edited SHIP file . then i created a shortcut
“C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\Bin\Release\HomeworldRM.exe” -overridebigfile

game wont launch . im kinda a noob at this so hopefully just made a silly mistake
thanks for all the help

the whole game doesnt launch and all i have uninstalled and reinstalled without any modding still not running dam u steam . ill try uninstall steam to

ok got the game running when i tried to mod. edited the HW1SHIPS file , done my editing created the Ship file in data then made the shortcut target
“C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\Bin\Release\HomeworldRM.exe” -overridebigfile
game launches but to remastered beta missing the singleplayer which is what im after

To launch the HW1 SP campaign I use the following after the target:
-dlccampaign HW1Campaign.big -campaign HomeworldClassic -moviepath DataHW1Campaign -mod compatibility.big -overrideBigfile

For the HW2 campaign:
-dlccampaign HW2Campaign.big -campaign Ascension -moviepath DataHW2Campaign -mod compatibility.big -overrideBigfile

launches right alright but still crashes out to windows saying access violation . im pretty much a noob that would be anything to do with my user access on the pc would it ?

Remember that .big files are not only in Data directory but also in DataUpdates directory. Those in DataUpdates directory are files that came with game updates, so they’re newer than those in Data directory, and those old files in Data directory may not work properly with the updated game engine.

1 Like

so whats my course of action gents

am i screwed ?

I would suggest making a very simple edit that we all know should work:

  1. Sort out your install so that it works and has no modded files at all

  2. Extract the kadeshi swarmer HOD file

  3. Place it in /data/ship/kus_scout/kus_scout.HOD

  4. Launch the game with these command line options:

    -dlccampaign HW1Campaign.big -campaign HomeworldClassic -moviepath DataHW1Campaign -overrideBigFile -luatrace

  5. Check if your Kushan scout looks like a Kadeshi Swamer…

  6. If not get back to us and paste the last part of the HwRM.log file.

thanks buddy your help appreciated loads ill try this now

Have you verified that works yourself? 'cause without checking, I can’t be certain the weapon joint names are consistent.

ill try anything at this stage

gonna have to uninstall steam and the works again crashes out of the launcher now. does it not like ssd r something ?

my pc does not like the remastered version i uninstalled the game and steam . Reinstalled went to click on the hw1 remaster and the launcher crashes but the classic works

by jasus the remaster is nice i just loaded up the classic and launched the campaign it really looks its age

Yes, it will work.

dam pc wont launch remastered even after a uninstall and a steam uninstall :(scream:

what is not launching ? The launcher or the game itself ?