(BL:TPS) Game Breaking Glitch: Permanently Stuck at Titan Robot Production Plant

I did some research after encountering this glitch and discovered that it has been known for years and Gearbox never fixed it. The glitch happens on all versions (PS3, 360, PC, PS4, XONE). During the objective “Install Felicity” of the mission “Let’s Build a Robot Army”, it’s possible to get permanently stuck and be unable to progress any further. Once the glitch is triggered, you’re basically screwed and must restart the game with a new character.

During the aforementioned objective, there’s a part where you’re ambushed by a bunch of Scavs in a room containing a furnace. Once you’ve killed them all, a large hangar door opens to let a few badass enemies enter the room. Now that the door is opened, you can continue in a hallway and reach the exoskeleton where you must install Felicity. Once you’ve installed her, you must escort her back to the Constructor. There’s a missable Badass Challenge associated with this part called “I Can Do This Alone”. By the way, I really hate missable challenges and I hope that they’ll never come back.

The glitch happens if you quit the game after the hangar door opens but before you complete the escort mission. Once you resume the game, the hangar door remains forever closed and you’re prevented from progressing any further. This is an extremely frustrating glitch that I’m surprised Gearbox never fixed despite the large amount of complaints all over the web about it. The glitch must also be quite common considering there’s a missable challenge associated with it. It’s when I reloaded the game because I failed it that I triggered the glitch. I assume that many people did the same and got stuck forever. Now I can no longer play the game.

It’s not the first time I’ve encountered glitches in BL:TPS, there are actually tons of them in that broken game, but it’s the first time I’m permanently stuck and unable to progress. I’ve been noting all the glitches I encountered while playing the game. I planned on posting them here to ask Gearbox to fix them once I completed the game so that I could compile them all in a single post. However, this glitch in particular made it impossible for me to finish the game and so I must post it now to get it fixed in priority.

Please fix this ASAP!

1 Like

It’s fixable with the same character if you can find someone on-line in the same play-through who has not yet completed this quest - join their game, and once you’ve killed Felicity you should be good to go in your own game.

Actually, even fast-travelling out and back, or save-quitting, once you’ve activated the switch to put the turrets on, will cause the same issue.

That doesn’t fix anything, though. I also don’t have PS+, so I can’t play online. Please, this has to be fixed because I can no longer play the game. There’s no excuse, it’s an unacceptable glitch that needs fixing ASAP. And thanks a lot for spoiling the game to me, I had no idea you had to kill Felicity.

I can’t fix anything - I’m just this guy on the forum, you know? You can put in a support request asking GBX to fix this known bug; just be aware that the support staff can’t do any more than file the request and tell you the same thing I already did.

Here’s the relevant support page - link to submit is just below the “Handsome Collection” title:

https://gearboxsoftware.zendesk.com/hc/en-us/categories/200330430-Borderlands-The-Handsome-Collection

Sorry about that - the game’s been out so long, it never dawned on me that you might not have played through the whole story yet.

2 Likes

[quote=“VaultHunter101, post:4, topic:1563551”]
I can’t fix anything - I’m just this guy on the forum, you know?[/quote]

Aren’t community managers hired by game developers to manage their forum? I know you’re not a developer, but you can redirect this to those who can fix it. And aren’t the developers also reading and posting in the forum? I know I’ve seen some developers and even a producer post here. One thing that amazes me is that this glitch has been known for years and Gearbox never fixed it. You even confirmed it yourself by giving me more details about the glitch. If I was a developer at Gearbox, I would have fixed the glitch as soon as I learned about it.

Are you telling me that sending a support request directly to Gearbox will be a waste of time because they’re just going to tell me the same thing as you did? Or did I misinterpreted it and you were only talking about this forum? I’m going to do as you suggested anyway. I’m not going to stop complaining until they fix this game breaking glitch.

It’s not because something has been out for years that everyone has seen or played it. I hadn’t played BL2 and BL:TPS yet when I bought the Handsome Collection. I played the Game of the Year Edition of BL1 a long time ago, then I played BL2 after buying the PS4 version a few months ago, and now I’m playing BL:TPS for the first time. I actually find it weird that BL1 wasn’t included in the collection, considering it works on the same engine and shouldn’t require that much extra work.

They are, but I’m not a Community Manager. Those guys have orange boxes around their posts. Forum moderators (all volunteers) have purple ones. If you’re referring to the title, you can find out more about it here. It just means I spend a disproportionate amount of my time lurking here and responding to requests for help wherever I can.

To be more specific, it’s a scripting conflict. Certain events in the game take place as soon as you trigger an event (e.g. by accepting a mission, operating a switch, travelling past a certain map point, etc.) The folks who created the script in this specific instance apparently didn’t anticipate that players might not push through the section where you go to get the power suit and escort it back. Some game-breaking script bugs have been fixed, but this one hasn’t been (yet?). It’s an unfortunate aspect of any game that has scripted elements in it - there are any number of similar glitches in the Fallout and Elder Scroll series, for example.

I’m just trying to set realistic expectations for you, since you’re already upset. A little back-story here might help too: Although the Pre-Sequel is GBX IP, the game was actually developed by 2KAus, an Aussie game studio owned by the series publisher, 2K. Unfortunately, 2K shuttered 2KAus permanently not too long after the launch of TPS as a result of the Aussie government drastically cutting tax incentives for game developers. The port of the game was handled by a different studio (Armature iirc).

GBX did release a couple of major updates after the port to XB1/PS4 that fixed a large number of issues (you can view the patch notes here.) I’m not sure why the Production Plant script glitch wasn’t fixed as part of that. If I had to guess, I’d go with it being more complicated (and potentially causing much more serious problems with game flow) than leaving it be. There still remain things in both BL2 and TPS that could be fixed, but the same is also try of BL1 (and plenty of games from other developers/publishers too.) I’m just not sure how realistic it is to expect any further updates at this point.

I meant that because I have been playing it since launch, I forgot that not everyone would have completed the whole game. To be honest, most of the folks I see posting on the forums for XB1/PS4 had all played on 360/PS3 previously - it’s rather rare to run into someone playing for the very first time.

A lot of people have wondered the same thing! I get the impression that originally, the plan was to actually do a remaster (both BL2 and TPS got some significant graphics work in the port to adapt to - and take advantage of - the new hardware; they weren’t straight forward ports by any means - and both platforms required major bug fixes even after internal QA/QC.) That seemed to have got nixxed when Microsoft brought out the whole backwards compatibility thing, so that XB1 owners can play the original BL1 without really any work on GBX’s part. Many of the regulars here keep pointing out to the community managers that a remastered BL1 (complete with important bug fixes) would be a major kick-off event for the eventual release of BL3. GBX is notoriously silent on their internal considerations, however, so who knows?

4 Likes

Ouch!

I never saved and quit in that part. But I easily could have. Especially since I’ve considered trying to do that highly improbable and stupid challenge (I’m convinced that you either need to be doing it way over leveled, and/or in a 4 player team so you can overwhelm).

Also, you can fix the problem yourself. In split screen. Start a new char and play through until that point and then bring in your first character and play through the mission. That SHOULD fix the issue.

And it’s worth it to raise a split screen char up to max level for TONs of reasons. So you’re not exactly wasting your time.

3 Likes

Good call. To @Flaxo: you’ll need to create a second profile on your PS4, and obtain a second controller (if you don’t have one already.) Other than that, though, you should be good to go (since neither profile will be using PS+). Having a levelled mule character you can bring in and out to store extra gear is always nice.

As an added bonus, if you have a friend over then they can play with you on the alternate account, without having to start a character completely from scratch.

1 Like

Yeah, this glitch is hugely frustrating, it locked my Claptrap out for a very long time until the only coop player I had at the time got up there too. I don’t blame @Flaxo for being annoyed!

Indeed. I am grateful for the support both 2kAus and then Gearbox have put into patching up TPS in a number of ways but there are a few residual things that I suspect will remain around.

2 Likes

Really? I thought the title “Community Badass” was just a fancy way of calling community managers. I was also lurking on the forum before I joined and I’ve seen you freaking everywhere. The way you were posting, your title, the fact that you were in most topics; I was under the impression that you were part of the forum staff. I was actually honored to get your attention so fast. Now I’m so sad because I feel cheated :frowning: .

Yeah, I noticed the purple boxes, I wasn’t really sure what they were. As for the orange ones, I noticed that developers and producers had them.

That explains it, then![quote=“VaultHunter101, post:6, topic:1563551”]
The folks who created the script in this specific instance apparently didn’t anticipate that players might not push through the section where you go to get the power suit and escort it back.
[/quote]

It should be taken for granted that anything is possible. All developers should anticipate such things, especially considering the fact that the whole thing is linked to a missable challenge. There are plenty of possibilities: power outages, leaving the game because of things to do in real life, fast-traveling to Concordia for grinding items or other stuff, etc. I happen to be a game designer myself and anticipating every single possibilities is one of my trademarks.

Don’t get me started on Bethesda games, they’re broken as all hell and completely unplayable. They make BL:TPS look like a perfectly polished game. I’ve reached a point in Fallout 3 where the frame rate drops below 1 frame per second, I’m not joking. I’m never buying a game from them ever again.

Yeah, I know the story, but I also know that Gearbox does continue to support the game with patches and hot fixes. Do you remember the freezing issues? You were a constant poster in that topic.

As someone who completes every single side quests, I tend to be over leveled in the main story missions, yes. There’s a trick for doing that challenge solo that involves blocking Felicity’s path by standing in her way.

That’s pretty tedious and annoying, really. There’s no reason for Gearbox to not fix this issue by releasing a hot fix before the next patch comes out.

So it’s not only tedious but I also need to buy an extra controller? No way man. As for having a mule, I do have one in BL2 because I ran out of space for storing items.

I don’t have friends to play games with me, hence why I only have a single controller for all of my consoles after the Wii.[quote=“hattieinduni, post:9, topic:1563551”]
Yeah, this glitch is hugely frustrating, it locked my Claptrap out for a very long time until the only coop player I had at the time got up there too. I don’t blame Flaxo for being annoyed!
[/quote]

Thanks, but if we complain enough together, we can have them finally fix that annoying glitch. I just want that glitch’s head strapped to a rocket and sent to crash on a nearby planet.

1 Like

To clarify: Orange posters are gearbox employees, both devs and community team (and marketing, and artists, and so on)

Purples like me are voluntary moderators, who were just ordinary forum users who got asked by the gbx community team to help out on the forum.

I can’t add much more that hasn’t already been said. I can guarantee, however that whilst gearbox (and any other game company) don’t want any glitches like this to exist, it’s part of the complexity of games they they inevitably will do.

Whether they have the resources to devote to a fix at this stage in the life cycle of the game is not known to me, but you never know.

1 Like

In principle, I completely agree with you. In practice, I’ve shot myself in my foot with my own programming code (not game programming, but same principles) often enough to know that it will happen sooner or later anyway - best laid plans and all that. Which leads to this:

As I said earlier, by all means file a support ticket. It never hurts to do that. Whether a fix will see the light of day, none of us here know - and I’d be surprised if the support desk folks knew either.

1 Like

But then you can also power level your main profile characters as well.

I always end up with tons of mules in Borderlands and play every character to max level. So I also end up wanting to power level at various points (from level 50 to 70 can be useful).

But yeah. I agree that it should have been patched. It’s sad that things like this remain. But at least there’s a couple ways through it. I’d help you online but I’m xbox one.

edit: post a related thread to this one in the PS4 section about looking to co-op online. Or you can join random players online until you find someone doing that mission. It tends to match you to players doing the same mission anyhow.

1 Like

Thanks for trying to help, but did you read my second post where I said that I can’t play online?

That’s what I did but they didn’t pay any attention at all. All they did was ask that I tell them everything again. I copy pasted my first post of this topic and yet they don’t understand despite how detailed it is. This isn’t a case of an obscure glitch that is difficult to reproduce but a case of an extremely well documented glitch that is always guaranteed to happen. And yet, they think it’s the former.

They still haven’t fixed the problem. They actually don’t seem very interested in working on it either. I’ve been told that the developers know about this issue but that they don’t have any plans on fixing it.

You can get out of that mess.
Simply Quit, save and quit back to the menu screen and load you character.
You spawn at the start of the map, door was open and the moonstone crate behind it was available to use again.

A helpful reply, but some 2 years late.