BL2 Crashing on Switch after Commander Lilith DLC Install

Is anybody Else having any problems with playing borderlands two on the Nintendo switch? Every time I try to load up the game after I got the Commander Lilith DLC, it errors me out and doesn’t even load past the title screen. I have tried everything from uninstalling and reinstalling the game to making sure that the game data wasn’t corrupt, even resetting my console. Nothing works. Does anyone know if there will be a patch or update for this, because the game is totally unplayable right now.

2 Likes

I have the same problem. My game was working fine until I downloaded the DLC from the eShop. There’s conflicting information on reddit, but apparently if you set your country to Japan over at this nintendo site, and THEN download the DLC, it’ll work? I haven’t tested this (still downloading) but I hope there’s some truth to it. I literally got to level 79 and then the crashes started!

2 Likes

Does it work?

it didn’t work for me, but a few people on /r/Borderlandsswitch have got it working for them. 2k twitter is getting people to post tickets and the devs are working on a patch but as far as why some have worked and mine didn’t, i have no idea, sorry.

1 Like

i try to install the software and the dlc separately but it didnt work too… my bl2 is unplayeble for alnost 1 week if i am wrong…

Same issue, I have tried changing country to Japan, installing a new memory card and formatting, downloading without DLC, downloading DLC first…nothing works. This is ridiculous gearbox

4 Likes

I got the issue aswell hope they fix it as fast as possible cus I’m have to play pre sequel until it works

1 Like

We are having the same exact problem on our switch. All was fine until we downloaded the dlc and now we get the same error message. Have tried everything but nothing works.

1 Like

I had the same issue several times. I submitted a ticket 2K over it. I can’t play the DLC until they have a patch but I am back in BL2 again.

I had to delete the software and the go to the Eshop and redownload it but hold “L” and it will say it’ll download software only, not the DLC and you can get back into BL2 :slight_smile:

Which l button ive tried and it doesnt dl any different. U should make a u tube video i bet u would get money for it
■■■■ id throw u money just to get mine to work

This does actually work.

  1. Make sure your Nintendo Switch has [the most recent system update.
  2. Highlight the game for which you want to remove DLC from the Nintendo Switch HOME Menu and press the + Button .
  3. Select Manage Software and then Delete Software .
  • This will not delete any Save Data.
  1. Select Delete to continue.
  2. Open the Nintendo eShop using the Nintendo Account that originally downloaded the game.
  3. Select your user icon in the top-right corner to access your Account Information.
  4. Select Redownload and locate the game from your list of previously downloaded titles.
  5. While holding down the L Button , select the orange redownload (cloud) icon .
  • If you do not hold down the L Button while selecting the redownload icon, you will redownload the game and all of your previously downloaded DLC.
  1. Select OK when a message appears that only the software will be redownloaded. The download will begin.
  2. If you wish to redownload some of the DLC later, follow our steps on [How to Redownload Individual DLC from the Nintendo
4 Likes

Make sure you select user icon

I got it to work and started a new Krieg playthrough and so far a few things have been off such as Hamerlocks first couple of missions such as cleaning up the berg and the midget riding a bullymong for the 2nd or third legendary weapon depending on your play-order. I started a new one again this morning and will report findings

So I finally got around to starting BL2 after clearing through BL1 and just freshly downloaded it yesterday. I launched it, got to title screen, hit A, and it crashed with an error. Googling led me here.

After reading around I didn’t know about the Lilith DLC and ended up ‘redeeming’ it (for free of course) on the eShop, downloaded it, and then launched the game again. Works perfectly fine now.

According to the game install I was on version 1.0.1 and still am after downloading the Lilith DLC. I didn’t have the DLC redeemed before downloading the game - not sure if this helps anyone or could help with tech support, but figured I’d drop in my experience for documenting the problem at least.

1 Like

Still doesnt work AND IM SO PISSED… Can’t even pass the “Press A” screen on BL2… PLEASE FIX GEARBOX

2 Likes

The best bet would be to file an official support ticket:

I had this issue as well. I had to delete BL2 and then go to download again but hold L when you click download and it will do software only, leaving out the DLC and allow you to play BL2 again. Hope this helps!

I also submitted a ticket with 2K and would recommend so they can fix for us :slight_smile:

1 Like

I did and it works thanks! I filled up a ticket as well. Can’t wait to try Commander Lilith !

1 Like

Is there a fix for this yet, I managed to get around it by uninstalling all BL2 game content then from inside switch eshop main page, select your Prof pic in top right corner, then go to redownload, then before clicking cloud icon next to BL2 ensure you are holding L down. To ensure this worked just check your software installation from within settings and on the right side it will say if dlc is present or not. I have tried this 3 times to ensure it has worked. We need a patch!

Edit: PS. I like the word ensure :+1:

1 Like

The commander lilith is only free till 3rd december on switch. I have currently uninstalled the game and dlc. Will I still be able to access it for free when this issue is patched later? How do I go about this?