Bl2 DLC failure to dload AFTER PURCHASE!

I have purchased the Mechromancer character pack (not outfit one i made certain of that) and the tiny Tina’s AoDK expac- both via credit card on my 360 in dlc menu on game start screen. BUT IT WONT LET ME ACCESS EITHER! Ive downloaded the pesky compatibility pack literally more than 10 times too and it continues to say “not downloaded”. I would either like a full refund or a proper solution! Im an ENORMOUS fan of this series (second time purchasing these xpacs due to a new 360) and i don’t want to lose faith because of technical difficulties!

Unfortunately, the 360 is known to have periodic issues with licensing etc. - had that happen a few times myself. A few things to try:

  • Clear the system cache on your 360 and do a full power off/on
  • Make sure when you reboot that you are fully signed in to your XBL account
  • Follow the steps to refresh your licence on the 360 if you haven’t already done so
  • Go to System > Storage > Games > Borderlands 2:
    • check to see if you have more than one compatibility pack; if you do, delete all the older (smaller) ones
    • check that the Mechromancer and TTAoDK packs are indeed on disk
    • you may want to go into your download history and “Download again” just to be on the safe side - this should fix any incomplete or corrupt downloads
  • Restart the console and sign in
  • Launch the game and don’t open the Downloadable Content menu
    • if it asks you to reinstall the compatibility pack, do so then immediately quit and relaunch the game
  • You should see MECHROMANCER as an option in the character select dialog; Unassuming Docks should also show up in the FT menu on any of your existing saves

If that doesn’t work, you can file a support ticket - make sure you explain what steps you’ve already taken.

Any refund request would need to go through the Microsoft Store, since they’re the ones who sold you the content. I’m not sure what the current refund policy is at MS though.

I had a problem getting the game to recognise my season pass and purchased content when I had to install on a new 360, and the above steps are what worked in my situation. That was complicated by the fact that there were two accounts on the 360, and my son had purchased items covered by my season pass - that really confused things. We did get it sorted though.

Thank you so much for the advice and quick response time, I will most certainly give this all a try!

Hope you have an excellent day, and may Vogon poetry never collide with your ears whilst your Babel Fish is active. :slight_smile:

So for some reason tht worked for mechromancer and pyscho but when i look at Tiny Tinas xpac it says Purchased, not downloaded. Then when i try dloading it tries making me repurchase which doesn’t add up :confused:

Are there any other accounts on the same system? ’

And regardless of what the items say in the in-game downloadable content menu, is Unassuming Docks showing up as a selectable location in the fast travel menu on any existing saves?

I had cleared the other accounts that had saves for bl2 (well cleared their caches that is) bc i figured they may be causing conflict with downloads, so that shouldn’t be an issue any longer- but ofc ill double check, better safe than confused/sorry haha. And the location is still listed as asterisked on the QT stations as if part of a not yet purchased pack :frowning:

Did any of the other account owners ever purchase the DLC? If so, that could be doing weird things. Otherwise, you’ve tried pretty much everything I’ve done. The folks on the support desk might have some other tricks up their sleeve though.