Bl2 runs out of video memory

so i used to play this on a crappier computer years ago and i uninstalled it back then because it was boring. now that the new dlc is out (and bl2 has like 4x the players that the pre-sequel has) i have reinstalled the game but on a newer, shinier pc. problem is that 2 minutes of being loaded inti the game i will get a “ran out of memory. closing” error. nothing on the help page or videos i have seen work. turned down graphics, updated drives and nothing. my pc has 32 gb or ram so idk why the pre-sequel works and not bl2.

1 Like

Are you using one of the RTX video cards? Because what you’re describing seems to be a common problem with them.

Check out some of the posts and a potential solution here

If the video memory error crops up when there are a lot of particle/visual effects going off on-screen (anything that obscures the screen) also try turning off ambient occlusion.

1 Like

Have the same problem while using a GTX960m with 2Gigs of VRAM (but the game rarely uses more than 1G) with 16GB of RAM

i re verified the files twice and my game worked for about 10 hours but now i get the same error. i am using a gtx 970 or something.

now its saying i need to free up space on my main disc even though i have 22gb free on it

Double check where the game is actually saving files or thinks its running from - as in, the full path with drive letter - sometimes things get a little misdirected.

uhh…how?

Should be in Steam settings?

hmmm cant find anything. found the drives my games have been installed on but nothing for individual games. im one of those where you need to explain things like moxi explained them in the pre-sequel “press the thingy three times then press the thingy again”.

For the game files that get executed, you can find them by right clicking on the name of the game (“Borderlands 2”) on the left side of the Steam LIBRARY and select “Properties”.

In the Properties screen, click on the “LOCAL FILES” tab. It will display which drive it is installed on and how much space is free USED.

This is the same place where you verified the integrity of the game files. Another useful option is to click on “BROWSE LOCAL FILES…”. That will open up a file explorer window in the folder where Borderlands 2 is installed.

For game saves, they are located in your Documents folder.

Unless you have moved your Documents folder to a different place, look in your “C:\Users\yourusername\Documents\my games\borderlands 2\willowgame\savedata” folder for a folder with an unique 17 digit name. If others have logged into Steam, then they will have their own unique 17 digit name, but usually there will only be one of them. Your saved games and profile.bin will be in there.

2 Likes

very helpful thanks! i did pretty much all of that except for the last part but didnt know what to look for. as for showing the free space in the “local properties”, it says disk usage not how much is left. mine shows 15.6k mb but i have over 470gb free on my F: drive.

1 Like

every time i re verify my game files it says one is corrupt/missing even after downloading the correct file. maybe that has something to do with it.

1 Like

No - that’s something to do with Steam DRM iirc. There will always be that one file gets flagged, but it’s not significant.

The “out of memory” error could be due to a lot of different things, not necessarily actual RAM/VRAM or disk space. One thing you could try doing is running the game using a different windows compatibility mode, such as Win 7 or 8.

If that doesn’t do it, the support desk may have more specific trouble-shooting steps for your system and graphics card.

tried the support desk first and did not work. im not going to try on a different version of windows since i dont want to mess anything else up on my computer. thanks for all the help

Sorry, you are correct, it is disk usage, not free.

I have all of the DLC installed, so that may explain why my disk usage is so much higher than yours.

Are you currently running windows 10? If so, check out the compatibility mode. It basically sets Win10 to run as though it was a different version on an application specific basis. There’s a tool that suggests what version to set for a specific program.

1 Like

tried 3 different versions and same thing. i read on some forum somewhere that it was made for a 32 bit system and was not working for some people using a 64 bit system. they offered no advice on how to fix it though.

1 Like

Well, the game certainly was made in the 32-bit era - base system targeted at launch was Win XP SP3. That said, other people have the game running just fine in Windows 10, so I don’t think that’s the issue - WIn 10 can certainly run 32-bit programs still. It’s more likely something to do with your specific hardware/software configuration.

Based on some of the other threads, some things you might want to check on:

  • Is the game using your graphics card, or trying to use hardware’s built-in graphics? There should be an option in your graphics driver settings - toggle it between states just in case it’s not displaying correctly
  • Are you running any additional graphics or audio software? A few of these have been known to interfere. If so, run without them for a bit; if that works, you can try adding them back in one at a time to see where the problem comes
  • Check your windows update version, as well as that of your graphics drivers - certain builds have also caused problems in the past. If you search for specific driver and update build versions, you should be able to determine if they are likely an issue.
  • Check your DirectX version - similar to above; some versions work better with BL2 than others.
1 Like

Rolling back drivers may help. I seem to remember a lot of these reports coming out a day or two after new drivers were released I think back in May. (As always, I could be very wrong!)

(Side note: I haven’t personally updated my drivers in some time because my video card is frankly a bit long in tooth and wouldn’t benefit from new tweaks and such, and optimizations for new games I don’t even own.)

that could be it! i have error reports that started back in may so i will try one more thing then roll the drivers back to before the may update. there was no info on what error was happening or for what app it was happening with. also i didnt play back then so i didnt think anything of it.