BL2 Won't Recognize USB Game Controller


(Kleptic) #1

computer recognizes the controller, as do other games. For some reason BL2 does not. Tried reinstalling driver, did not fix problem. it’s a generic wired controller from radioshack (2603666) and it works fine on other titles so I don’t think it’s the controller. Any help or ideas would be greatly appreciated.


#2

A few suggestions from me:

  1. Try plugging in the controller after starting up BL2 when you are at the main menu.

  2. Have you tried the official xbox controller?

  3. Have you contacted Gearbox Software Support yet? If not, you can use the link here: https://gearboxsoftware.zendesk.com/anonymous_requests/new


(˙pǝsɹǝʌǝɹ uǝǝq sɐɥ ʎʇıʌɐɹƃ ʃɐuosɹǝd ʎW) #3

Have you tried a different USB port? It should reinstall itself on the new port.


(Kleptic) #4

I tried switching USB ports to no avail. I did discover a different way to fix though. The controller has a way to switch input mode. I had to turn on the different mode BEFORE I strarted up BL2. seems to work fine now. Thank you for for the suggestions.