Bl3 Keeps crashing while playing

For the past week I’ve been having issues with borderlands 3 constantly crashing while in the middle of gameplay. I’ve tried numerous fixes: verifying file integrity, reinstalling graphics drivers, and completely reinstalling the game, but nothing has worked. Here are just some of the error messages I have gotten.

P.S. This is the steam version!
error2 error3
error

Are you playing on Mayhem and if yes, have you tried re-rolling your modifiers? Some of them, particularily ones that involve some kind of laser or damaging beam (particularily chain gang) are a bit infamous for causing crashes or freezes.

If not, the customer support may be able to help you out (and of course, there’s at least a chance it’s gonna get fixed in the patch this thursday anyways).

1 Like

I’m using the mayhem modifiers that drop the elemental pools and the black death spirit

1 Like

Seems to be an issue with linking to shift.

I’m having a similar issue on the Epic platform - I get these errors as well as one (which I get most often) about my video drivers.

I’ve updated my video drivers to the latest version.

I’ve disabled all non-Microsoft startup services.

I’ve reinstalled the game.

My steam, epic and shift accounts are all linked.

The issue happens every time I get into the Golden Chariot - game crashes.

Can’t progress the main storyline from here.

i7 9700K; 32GB RAM; AMD Radeon RX 5700 XT - seems to be ok with lots of other games.

UPDATE: I thought I might do some side missions in the meantime and when I pressed ‘Q’ to respawn my vehicle (which had been a cyclone), there I was behind the wheel of the Golden Chariot! Strange …

When you’re on a vehicle-specific mission, it does that unless you choose the interact option first. Same thing with the side quest in Floodmore Basin where you have to do all those ramp jumps in a special racer.

I check shift.gearboxsoftware.com and my steam account is already linked to Shift

From reports in that other thread, some have had to unlink, and relink their shift accounts. That’s worked for some, but I’ve also seen some that it hasn’t worked for.

Whoomp whoomp…

The bug finally bit me. I was good this morning, and tried launching while and it crashed in the Droughts after securing the Propaganda Center in TVHM MM4 with Lootsplosion & Po Party active en route so Sun Smasher camp with Powerful Connections also active Level 44 Amara with Phasegrasp, an Alchemsit, Laser Sploder, Superball, Helix, Hex, Transformer and Deathless.


I unlinked shift and it crashes as soon as I started mantling near the sunsmasher New U and enemies aggrooed.

Gonna try reconnecting to Shift next.

I think that’s more for the crash during sign-in rather than while playing the game.

@masterjp9 @Isthiswill - maybe try nuking the local appdata for BL3 before launching the game? Stuff in there is supposed to be cleared when the game shuts down; obviously that doesn’t happen on a crash, but I’m not sure how well the game cleans up that folder when it restarts.

%LOCALAPPDATA%\Borderlands 3\Saved

Oh, the DLC4 update was given as a fix by the gbx support ticket response, and that did actually get me back up and running. I just neglected to update this thread since I responded with my results in a similar one. Thanks for reaching out with a potential solution though!

1 Like

i was having the same prolem… just re-roled my modyfiers without the moob mentality one…
AND IT STOPPED CRASHING!!!