Blender DAE Exporter for HWRM

How do I add one? There is a texture, but I dont know how to make it diffuse.

In the .blend you uploaded there was no image file assigned. In Blender, change the image type from “generated” to “image” and select your appropriately named image file. Make sure it’s in the same directory as your DAE.

I must be missing something here. Just to double check I downloaded the zip I uploaded which contains cube.blend and cube_DIFF.tga.

When I opened it up this is what it looked like.

I thought this shows that I have:
1: selected the image in the image editor window
2: connected the blend to the .tga
3: named the image
4: have all my naming stuff correct.

Can you elaborate on exactly what you mean? I also just exported a .dae and it properly loads up and has its texture when viewed in visual studio.

1 Like

Actually this error is what happens when you don’t have the specular type set to ‘Phong’ in the material.

@pbobbert: switch the dropdown in the circled area to Phong. It’s CookTorr by default.

4 Likes

Hey that worked! Thanks a bunch. I do still have one problem though, If I zoom out past a certain point my ships disappear. Now I remember you said you only need LOD0, but could that be causing the issue?

1 Like

Remove all NewShipType.upLOD and NewShipType.downLOD lines from the .ship file.
You should also download and take a look at the examples on the Steam Workshop.

2 Likes

Ok this one is bugging me. I’m making a really simple navigation buoy, so I created a cube, clicked convert to ship, copied to collsion mesh, added materials and exported. It looks fine in DAENerys and HODOR doesn’t throw any errors, but the game CTDs and spits out this:

Unknown mesh group type (1) -- FATAL EXIT -- basicmesh/602:! --stack trace--        

How is that I can make ships in blender but this cube is defeating me?!

Please can someone tell me what silly mistake I have made…?

EDIT: Something stranger is going on here. My HODOR appears to be broken. I took a different DAE file that I ran through HODOR on the 17th Jan, when it worked fine in game. I re-ran the same DAE file through HODOR today (no changes to the DAE) and now I get that same “Unknown mesh group type” error… None of the HODOR files have been updated, so it must be somthing else… Windows Update? @PayDay 's map editor? They are the only two things I have changed. Has anyone else had this issue?

EDIT2: the last windows update was before 17th Jan, so it can’t be that. The only things I know of that have changed are:

  1. Some steam updates
  2. The map editor
  3. Some starcraft 2 upates

I think #1 is the most likely, in which case is anyone else seeing this?

EDIT3: panic over, I reinstalled the HWRM Toolkit from steam and now it works :slight_smile:

2 Likes

So… bad version of HODOR?

Or corrupted. Strange because HODOR was not updated…

Can anyone help to explain this? I have a ship that I am working on, at this point I can load it into game. However there are two issues. One, when I export the my .blend to a .dae and hodor it, part of the ship becomes rotated. Interestingly enough this issue is not visable when viewing the dae in visual studios.

The second issue is that all my textures get flipped. So while they show up correctly in blender, (and in visual studios) they are all backwards once I get into game.

In case it is relevant (i have a feeling it might be) the ship is created from multiple meshes, such that my hierarchy looks like this. I want to keep my meshes separate, is this the right way to do it?

ROOT_LOD[0]

JNT[Default]

MULT[hull]
MULT[leftgun]
MULT[rightgun]
MULT[missile1]
MULT[missile2]

JNT[EngineNozzle1]
JNT[Weapon_L]
JNT[Weapon_R]

1 Like

There can be some weird things going on because of Blender’s coordinate system. The easiest and fastest way to see if your ship is correctly rotated without HODORing, is to just load it into DAEnerys.

If that’s not an option or doesn’t help, check if you applied the rotations in Blender.

currently DAEnerys (7000) doesnt work for me, I have the same issue as @Nathanius

That said I tried it with an older build 6746 and interestingly enough it shows the rotation as correct, but the textures are still backwards.

edit:
I have found that flipping all the UVs will sort of fix my issue. As an added note this is only happening on one of my ships. There seems to be some discrepancy between how blender and visual studios view .dae files and how DAEnerys and HWRM do, but again, only for this one ship. All of my other ships are just fine.

1 Like

Do you use custom shaders?

Weapon meshes should be children of ROOT_LOD[0], not JNT[Default] (actually, they should be children of their own weapon empties, which are in turn children of ROOT_LOD[0]. This is what the ‘Mesh to Weapon’ button is for.)

I’m not sure what’s going on with the UVs from your description. Maybe something up with your normals? Select each mesh, go to edit mode and click the ‘Recalculate’ button under the Shading/UVs tab and try re-exporting from there.

1 Like

@pbobbert

I dont think so? How do I check?

@DKesserich

Im not sure I understand. Is a mesh weapon something special? I simply have a mesh that I called leftgun and rightgun. Can you explain what you they are?

Edit:
I did some clarifying tests to put all the information I have together.

Ship 1. Scratch built. Shows up correctly in blender, Visual Studios, DAEnerys and HWRM

Ship 2. HW2c bomber exported via cfhoded. Reversed UVs upon exporting. Shows up correctly in Blender, and Visual Studios. Backwards in DAEneys and HWRM.

Ship 3. HW2c bomber again exported via cfhoded. UVs not reversed. Shows up backwards in Blender and Visual Studios. Correct in DAEnerys and HWRM.

So far I havnt been able to come up with an explanation. It has to be something to do with exporting. But I cant figure it out. How else could it work on one ship and not another?

1 Like

That’s not the way I would do it. I would:

  1. RODOH the HW2 classic HOD file for the hgn_attackbomber - you now have a DAE with all the correct joints
  2. Import the DAE into blender using the blender dae importer
  3. Export the texture files from CFHoded for the HWRM hgn_attackbomber
  4. Swap the texture files in Blender and re-export (remembering to add the “_FMT[DXT1]” to the end of the image names, because the importer misses them off…)
  5. HODOR the exported DAE file
1 Like

How will exporting the ship as a DAE differ from and .obj? That said ill give it a try and see what happends. But I thought rodoh only works on HW2c_RM hods. Aka gonna have a bad time when I get to any custom HW2 hods.

Right now im trying to establish a workflow using blender, I was following the export steps from [TUTORIAL] oldHOD to nuHOD with Nathanius

Just to double check though, RODOH doesnt work on any HWRM hods right?

Post HWRM version 2.0, that is correct.

Because obj is just a model format, RODOH produces the joint structure as well. It will save lots of time.

Yes, that’s why I said to use RODOH on the classic HOD. The HW2 classic models are the same as HWRM. They only changed the textures. I believe the workflow I described is basically the one gearbox used. For HW1 ships it wouldn’t work because the models are different.

Even pre HWRM 2.0 HODs will not work with RODOH, only classic HODs.

While that is true technically the pre-2.0 HODs could be got at by CFHodEd’s partially updated version