Blender DAE Exporter for HWRM

Please can someone help me work out why this DAE file is not generating a MAD file? I have HOLD_ANIM etc. all set up and a joint is animated.

@PayDay @radar3301 the animations play fine in DAENerys…

1 Like

The only thing I can think of is that your animations are bezier format with in and outtangents instead of linear, but I just know someone is going to come along and tell me that HWR supports bezier now.

1 Like

I tried swapping “BEZIER” to “LINEAR” directly in the XML file, but it still didn’t produce a mad file :frowning:

I have other dae files that I made with max that contain BEZIER keyframes and they work. I really can’t spot the problem here, it has the hold anim node and the animation definitions…

1 Like

I also tried some things, without success. This is strange, maybe just recreate the DAE? :stuck_out_tongue:

There seems to be something odd about the durations. Is blender’s frame rate not 30 fps?

By default I believe it’s 24fps.

Ok, it was related to the frame rates. This tag in the DAE file specifies the keyframes in time (seconds).

<float_array id="xxxxx-input-array">0 1.25 2.5 3.75</float_array>

I was assuming 30fps, so it worked when I corrected it to:

<float_array id="xxxxx-input-array">0 1.0 2.0 3.0</float_array>

In other words, unless what you specify in the ANIM[xx] nodes exactly matches the keyframes, you will not get a MAD file…

Interestingly, the max-generated DAE has the following information specifying a frame rate and start and end times:

  <extra>
	<technique profile="MAX3D"><frame_rate>30.000000</frame_rate></technique>
	<technique profile="FCOLLADA">
		<start_time>0.000000</start_time>
		<end_time>3.000000</end_time>
	</technique>
  </extra>

There is no equivalent in the Blender-generated DAE. Its presence does not seem to matter to HODOR…

2 Likes

Nice find! This can be implemented into DAEnerys to warn modders. :slight_smile:

2 Likes

OK, so now this is what my blender animation looks like:

Great, but in game and in DAENerys:

image

What is strange is that the joint is correctly positioned until the animation plays, then it rotates by 90 in x… I tried applying a rotation to my HOLD_ANIM rotation node in case it was that, but it had no effect.

Any ideas?

1 Like

I don’t know what went wrong, but I sort of like that new dolphin look :wink:

Imagine seeing a swarm of these swimming towards you… :stuck_out_tongue_closed_eyes:

2 Likes

As a workaround I can set things to their correct “static” state as a keyframe at “1” and give all my actual animation keyframes an x rotation of -90. It acheives what I want, but it seems non-ideal…

1 Like

At a guess, I’d say your wing joint isn’t inheriting the rotation from the Root joint. There’s two ways to fix this: clear parent on the wing joint (alt+p), then select the root joint and clear its rotation (alt+r) then rotate the wing joint -90 on X and apply rotation, then make it a child of the root joint, then rotate the root +90 on X again (and do not apply that rotation).

OR: clear parent on the wing joint, switch one of your viewports to python console, and enter D.objects['Wing Joint Name'].parent = D.objects['Root Joint Name'], which will force the child to inherit any transforms from the parent.

I think it’s a bug that the parent_set operation that ctrl+p does doesn’t inherit transforms when you don’t select the ‘keep transform’ option, but I don’t know if it’s ever been reported, or where in the Blender development priority list it sits if it has been.

5 Likes

Thanks, that solved it! You are a blender guru.

1 Like

I see what you did there.

1 Like

… I didn’t… :confused:

1 Like

https://www.blenderguru.com/

2 Likes

@dkesserich does your exporter include the Tolerance parameter on dockpaths? They keep coming out as Tolerance: 1 when I check the output DAE in DAEnerys.

Edit: DERP. It uses the draw size. My bad.

1 Like

Got an issue. I can’t export the ship from blender as a hw .dae file. Any clue on how to fix this?

  1. Use the updated toolkit: [TOOL] Blender HWRM Toolkit

  2. When you have an issue, people CANNOT help if you just say “it doesn’t work”. You need to provide some details - e.g. it installed fine, I see the option to export a dae, but when I click on it a pink box pops up with the message “stegasaurus error”. Then other people who experienced the stegasaurus error might be able to tell you how they resolved it, or the person who made the tool can work out how to fix it.

3 Likes

I see…I’ll check your toolkit and see if anything changes

1 Like