Blender DAE Exporter for HWRM


(Christoph Timmermann) #202

As DKesserich said, there are some things wrong with your DAE/Blend.
I would also suggest trying out DAEnerys for testing your ships. (or even create them)


(Pbobbert) #203

@DKesserich @sastrei

I have tried that and I have the same issue. I made a new cube.blend which has two engines and one gun as a replacement for the hgn_interceptor. Again I can make the .dae and .hod just fine but the game crashes upon loading the universe. Can you guys take another look at this and see if there is something wrong with it?

https://drive.google.com/open?id=0BztIxF80g70yV0ZCWXhfbzdNUGs

Also something that would help me is if someone could provide a working .blend which can replace the hgn_interceptor so I can try to use it as a template. It might also help me debug incase something else is causing a problem.

@PayDay
What is DAEnerys supposed to do? I actually cant get it to run, it just crashes instantly upon opening.

Thanks


(ajlsunrise) #204

If you could describe your crash in more detail, preferably with screenshots and/or by pasting the contents of the manifest.log and log.txt inside [code] tags over at the DAEnerys thread, we’ll try to resolve your crashing issue.


(Sastrei) #205

@pbobbert Your image name is wrong and you don’t have an actual image with a matching name assigned. IMG[cube]_FMT[DXT1] should be IMG[cube_DIFF]_FMT[DXT1] and your image texture name should be cube_DIFF.tga


(Pbobbert) #206

Is my collision data also supposed to have a material and texture?


(Sastrei) #207

No, not for the collision mesh.


(Pbobbert) #208

@sastrei

PayDay found my first error, I did not understand that the weapon name mattered, I used Gun because it was in the tutorial. For those reading for the future, look in the ship file to determine what it needs to be called.

If it says StartShipWeaponConfig(NewShipType,"Hgn_KineticAutoGun","Weapon_FrontGun","Fire") then the weapon must be named Weapon_FrontGun, like in the hgn_interceptor.ship.

Having made those changes I now have the following error when I run hodor.

DAE->HOD: MAT[cube]_SHD[ship] lacks Diffuse channel, is required for SHADER.MAP processing!

The result is that my ships are completely invisible but they have engines and weapons that work.
I have looked everywhere for a checkbox for making a material a diffuse channel but have found nothing.

Any ideas what could be causing this? I have attached my newest copy, and for the record I have tried naming the image both cube_DIFF and cube_DIFF.tga, both have the same results.

https://drive.google.com/open?id=0BztIxF80g70yTjhCanZqNElDUlk

These are my hodor parameters, I got them from here and just changed my paths to match my game

## My HODOR Params - by Timmy

= -$HWRM_BASE=C:\Games\SteamC\SteamApps\common\Homeworld
= -$SHIP_NAME=cube
= -$SHADER_MAP=$[HWRM_BASE]\GBXTools\HODOR\SHADERS.MAP
= -$SHADE_OPT_LOADDAE=Force8888
= -$HOD_SAVE_OPTS=ForceScars FilterScars=thruster,bay
= -$CONVERT_IN=D:\HomeworldTFS\ship$[SHIP_NAME]$[SHIP_NAME].DAE
= -$CONVERT_OUT=D:\HomeworldTFS\ship$[SHIP_NAME]$[SHIP_NAME].HOD
= -do=convert
= -action=null
= -wait


(Nathanius) #209

There is no diffuse texture!


(Pbobbert) #210

How do I add one? There is a texture, but I dont know how to make it diffuse.


(Sastrei) #211

In the .blend you uploaded there was no image file assigned. In Blender, change the image type from “generated” to “image” and select your appropriately named image file. Make sure it’s in the same directory as your DAE.


(Pbobbert) #212

I must be missing something here. Just to double check I downloaded the zip I uploaded which contains cube.blend and cube_DIFF.tga.

When I opened it up this is what it looked like.

I thought this shows that I have:
1: selected the image in the image editor window
2: connected the blend to the .tga
3: named the image
4: have all my naming stuff correct.

Can you elaborate on exactly what you mean? I also just exported a .dae and it properly loads up and has its texture when viewed in visual studio.


(D Kesserich) #213

Actually this error is what happens when you don’t have the specular type set to ‘Phong’ in the material.

@pbobbert: switch the dropdown in the circled area to Phong. It’s CookTorr by default.


(Pbobbert) #214

Hey that worked! Thanks a bunch. I do still have one problem though, If I zoom out past a certain point my ships disappear. Now I remember you said you only need LOD0, but could that be causing the issue?


(Christoph Timmermann) #215

Remove all NewShipType.upLOD and NewShipType.downLOD lines from the .ship file.
You should also download and take a look at the examples on the Steam Workshop.


(Taiidan Republic Mod) #216

Ok this one is bugging me. I’m making a really simple navigation buoy, so I created a cube, clicked convert to ship, copied to collsion mesh, added materials and exported. It looks fine in DAENerys and HODOR doesn’t throw any errors, but the game CTDs and spits out this:

Unknown mesh group type (1) -- FATAL EXIT -- basicmesh/602:! --stack trace--        

How is that I can make ships in blender but this cube is defeating me?!

Please can someone tell me what silly mistake I have made…?

EDIT: Something stranger is going on here. My HODOR appears to be broken. I took a different DAE file that I ran through HODOR on the 17th Jan, when it worked fine in game. I re-ran the same DAE file through HODOR today (no changes to the DAE) and now I get that same “Unknown mesh group type” error… None of the HODOR files have been updated, so it must be somthing else… Windows Update? @PayDay 's map editor? They are the only two things I have changed. Has anyone else had this issue?

EDIT2: the last windows update was before 17th Jan, so it can’t be that. The only things I know of that have changed are:

  1. Some steam updates
  2. The map editor
  3. Some starcraft 2 upates

I think #1 is the most likely, in which case is anyone else seeing this?

EDIT3: panic over, I reinstalled the HWRM Toolkit from steam and now it works :slight_smile:


(ajlsunrise) #217

So… bad version of HODOR?


(Taiidan Republic Mod) #218

Or corrupted. Strange because HODOR was not updated…


(Pbobbert) #219

Can anyone help to explain this? I have a ship that I am working on, at this point I can load it into game. However there are two issues. One, when I export the my .blend to a .dae and hodor it, part of the ship becomes rotated. Interestingly enough this issue is not visable when viewing the dae in visual studios.

The second issue is that all my textures get flipped. So while they show up correctly in blender, (and in visual studios) they are all backwards once I get into game.

In case it is relevant (i have a feeling it might be) the ship is created from multiple meshes, such that my hierarchy looks like this. I want to keep my meshes separate, is this the right way to do it?

ROOT_LOD[0]

JNT[Default]

MULT[hull]
MULT[leftgun]
MULT[rightgun]
MULT[missile1]
MULT[missile2]

JNT[EngineNozzle1]
JNT[Weapon_L]
JNT[Weapon_R]


(Christoph Timmermann) #220

There can be some weird things going on because of Blender’s coordinate system. The easiest and fastest way to see if your ship is correctly rotated without HODORing, is to just load it into DAEnerys.

If that’s not an option or doesn’t help, check if you applied the rotations in Blender.


(Pbobbert) #221

currently DAEnerys (7000) doesnt work for me, I have the same issue as @Nathanius

That said I tried it with an older build 6746 and interestingly enough it shows the rotation as correct, but the textures are still backwards.

edit:
I have found that flipping all the UVs will sort of fix my issue. As an added note this is only happening on one of my ships. There seems to be some discrepancy between how blender and visual studios view .dae files and how DAEnerys and HWRM do, but again, only for this one ship. All of my other ships are just fine.