Blender DAE Exporter for HWRM


(Taiidan Republic Mod) #242

OK, so now this is what my blender animation looks like:

Great, but in game and in DAENerys:

What is strange is that the joint is correctly positioned until the animation plays, then it rotates by 90 in x… I tried applying a rotation to my HOLD_ANIM rotation node in case it was that, but it had no effect.

Any ideas?


[MOD] Resurgence WIP
(jelrak) #243

I don’t know what went wrong, but I sort of like that new dolphin look :wink:

Imagine seeing a swarm of these swimming towards you… :stuck_out_tongue_closed_eyes:


(Taiidan Republic Mod) #244

As a workaround I can set things to their correct “static” state as a keyframe at “1” and give all my actual animation keyframes an x rotation of -90. It acheives what I want, but it seems non-ideal…


(D Kesserich) #245

At a guess, I’d say your wing joint isn’t inheriting the rotation from the Root joint. There’s two ways to fix this: clear parent on the wing joint (alt+p), then select the root joint and clear its rotation (alt+r) then rotate the wing joint -90 on X and apply rotation, then make it a child of the root joint, then rotate the root +90 on X again (and do not apply that rotation).

OR: clear parent on the wing joint, switch one of your viewports to python console, and enter D.objects['Wing Joint Name'].parent = D.objects['Root Joint Name'], which will force the child to inherit any transforms from the parent.

I think it’s a bug that the parent_set operation that ctrl+p does doesn’t inherit transforms when you don’t select the ‘keep transform’ option, but I don’t know if it’s ever been reported, or where in the Blender development priority list it sits if it has been.


(Taiidan Republic Mod) #246

Thanks, that solved it! You are a blender guru.


(Christoph Timmermann) #247

I see what you did there.


(ajlsunrise) #248

… I didn’t… :confused:


(Christoph Timmermann) #249

https://www.blenderguru.com/


(Sastrei) #250

@dkesserich does your exporter include the Tolerance parameter on dockpaths? They keep coming out as Tolerance: 1 when I check the output DAE in DAEnerys.

Edit: DERP. It uses the draw size. My bad.


(Hero Crafter 1987 (Homeworld Universal Conquest Mod)) #251

Got an issue. I can’t export the ship from blender as a hw .dae file. Any clue on how to fix this?


(Taiidan Republic Mod) #252
  1. Use the updated toolkit: [TOOL] Blender HWRM Toolkit

  2. When you have an issue, people CANNOT help if you just say “it doesn’t work”. You need to provide some details - e.g. it installed fine, I see the option to export a dae, but when I click on it a pink box pops up with the message “stegasaurus error”. Then other people who experienced the stegasaurus error might be able to tell you how they resolved it, or the person who made the tool can work out how to fix it.


(Hero Crafter 1987 (Homeworld Universal Conquest Mod)) #253

I see…I’ll check your toolkit and see if anything changes