Borderlands 2 and windows 10 issue [SOLVED, MISSING DirectX Architecture!]

I installed and attempted to play borderlands 2 on a freshly made pc/fresh install of windows 10 today. Issues from the start! The game starts, but upon the 2k logo, the video freezes and the sound continues to play. Things I have done to fix this:

  1. made sure I was using my correct AMD drivers for gpu. I uninstalled every other driver except the basic display driver, booted up into safemode and ran DDU, rebooted in normal to install AMD 16.1, rebooted and no-go.

  2. ran the .exe from the steam folder, then ran it as administrator, then ran it in compatibility for windows 7… no go

  3. uninstalled, reinstalled to a new drive. no go. uninstalled/reinstalled back to os drive. still nothing.

any other ideas?

amd 9590, 16gb ram, r9 390, 1000w psu, 2 x 850 evo ssd’s, and as mentioned w10 os (professional, clean install and no upgrade). thanks in advance

edit 1:

  1. ran steam’s game game cache integrity tool. one file fixed. still no dice

I can confirm that it’s possible to play the Steam version in Windows 10 without an issue (for my combination of hardware/drivers anyway). Try adding -NoLauncher to the startup options (right click on the game name in your library, select Properties, on the General tab, click the Set Launch Options button, and add that text. If it’s just an issue with those .BIK movie files, you can at least get the game started (although these file types are also used in game, but let’s see if you can’t get past the introductory videos first).

I gave what you suggested a go. However I am having difficulty finding what you are asking me to change. I am not seeing the Startup Options, or the Set Launch Options button in the General tab of the Application Properties.

Am I in the wrong spot, looking at the wrong things?

its not steam library in your hdd but in your steam client app.
image

Thank you lureifaysmd for the redirection! :slight_smile: I found what was asked of me to do.

image

I tried launching Borderlands 2 from Steam Library, no dice. Then I tried the Borderlands 2 Application from the installed drive location, and no go there either.

Thanks @lureifaysmd… should have been more specific.

@megaphone66640, what are those Borderlands2.exe.xxxx.STEAMSTART files? Those smell like log files from the game hanging (I don’t have those in that same directory). If you open those with Notepad, do they provide anything legible (and if so, anything helpful)? It may be time to open a ticket with support.

I was hoping you would see those lol! I opened them with notepad like you asked and yea, bunch of hieroglyphics. doh! Might be right about opening a ticket.

I checked my event viewer last night to see if some of my fixes stuck, and I did come across a couple bl2 errors, to my surprise.

image

here’s the 1026:

image

and the subsequent 1000:

image

seem’s like something is missing according to the 1026. going to try reinstalling to a fresh location.

I just disabled windows defender on my w10 to download and reinstall bl2 to see if that helps

Edit: nope, still getting that same game cache integrity error from steam, and can’t get video to play nice on launch yet. Bummer

Edit two: I made a ticket. Will post back upon results. The file missing isn’t a game file but some .net v4.

Here’s what I have installed along those lines in case it helps (it seems like any game that uses this brings over the specific version it needs upon installation :confounded:

Thanks for showing me that ss. Seems like you have a bit more architecture on your is than mine. That’s weird. I’ll post mine up tomorrow for comparison

I know I definitely don’t have that specific architecture you have highlighted… That could be what’s giving me all this trouble. I’ve tried to manually install .net v4, but w10 won’t have it ugh

So yea, here’s my Installed Programs list. Note the architecture difference, and I know that I didn’t uninstall any of those! I wonder why mine is so different. I turned off my anti malware stuff (malwarebytes, wdefender, wfirewall) for the install, too.

The C++ Redistributable stuff? I think those are installed by the different sets of software that we have (since they seem to need very specific versions of that software): I don’t know how many of those come stock with Windows 10, and I certainly don’t know which program favors which version, but this should get the support team on the right track.

That’s a good point. Forgot about other programs lol duh. Guess who got a little bit tunnel-visioned? This guy. XD

Ticket is up. Dxdiag msinfo and -nolauncher covered with 2k tech support. Thanks you two for pointing me in the right direction! I’ll post whatever progress I get. :smile:

Hey there megaphone66640 , Are you still having trouble with starting on Windows 10 ?

If yes .Then try this step it help me couple of times . delete your current Borderlands from your Partion
D:/ and try install it on C:/

But also before you do this try the following if you haven’t already done it . Go to Windows “Update & Security” , then select " For developers" where there are 3 seletions to choose from . Select “Sideload apps” i Hope this may help you.
image

Hi painstiller71! I am still having issues with the video freezing. Thank you for giving me a suggestion! I gave what you wrote a go, and I am still having the issues.

2k tech support also had me turn off the intro movies through the game engine .ini file. Unfortunately, that didn’t work either.

Thanks again for the suggestion. Definitely not sure whats going on here so anything can help. :smile:

Hello! I am happy to report that I, quite literally, stumbled on the solution to my problem. My problem was, upon installing Borderlands 2 from Steam, my machine was apparently still lacking the appropriate DirectX architecture. I was under the impression that everything Borderlands 2 needed was installed. This was not the case.

Today I installed OBS software so I may stream to my Twitch profile. As I ran the installation of OBS, the wizard pointed out that I needed to install some additional DirectX files, to which I proceeded to download and install.

Then I installed OBS, tweaked its settings, yadda yadda… then I had a thought about the DirectX files I just recently installed, that maybe I should give BL2 another go?

Voila! (Really.) That is what was fouling me up. Hope this helps someone else. Thanks everyone who stopped in and had the patience to read and chime in on my particular issue, because it really helped to figure out what WASN’T the issue. Thank you all. :acmaffirmative:

Glad things worked out… sounds like you got lucky stumbling into that? I am still under the impression that everything Borderlands 2 needs to run will come with an install, even though that didn’t appear to happen in your case.

I think the installer just looks to see if DX is installed, and if so, doesn’t try to reinstall it. I guess those files got corrupted or deleted somehow. I use the non-web installer of DX 9 for older games, so I’ve never had an issue with it. I’m glad Mega got their issue resolved though.

Glad everything pand out just fine then crazy that Direct X was fault the whole time.