Borderlands 2 Fatal Error

Every time I start-up the game from steam, it starts normal like every other time. But after I press play on the small menu, it loads for a few seconds and then a window pops up that says:
"Fatal error!
Address = 0xd6d174 (filename not found)
Address = 0x6dd174 (filename not found)"
This happens every time, I’ve even tried uninstalling and that didn’t work either.

Have you tried verifying your local files?

I had this problem and I just managed to fix it, I tried reinstalling, didn’t work, updating drivers, also nope.
I tried even removing my profile (I thought it was a corrupted profile), nope

Turns out Discord was the main problem, if you have Overlay for Discord enabled, it’ll crash Borderlands

1 Like

Holy crap, thank you! I would have never tried that and I never knew it would be able to crash my game. I only got Discord yesterday. xD
Again, thanks.
(Yes it worked)

Yeah I honestly wasn’t expecting Discord to be the cause for it all too, I installed it a couple of days ago and since then it’s been causing a whole lot of issues with Borderlands t(w)oo (Excuse the pun)

I don’t have discord and it’s still doing it to me.

Is there any other way? Only video I’ve found is in another language.

Closed to avoid further necromancy (plus duplicate posts)