Borderlands 2 - FPS Drops or Low FPS - 2019

(Cgxel) #1

I’m playing on a 2080 Ti and I noticed FPS drops days ago, then I found out people were saying it was PhysX fault.

But upon tweaking a simple thing I’m able to play with everything set to high including PhysX and my FPS does not even drop a little bit, just not a bit.

So I was wondering, is there anyone still having problems?

FIX that should work for most people -----------------------------------------

Three notes:
1.- Tested on Windows 10 x64, 1803 and 1809
2.- This setting could increase latency on some games, Borderlands 2 is NOT one of them.
3.- It worked on a non-gaming laptop, was able to play with PhysX set to High

NVidia Users: (any driver works, tested on 3xx and 4xx drivers)

  1. Make sure you have NVidia drivers installed
  2. Open NVIDIA Control Panel
  3. Click on Manage 3D Settings
  4. Click on Program Settings tab
  5. Click on “Add”, look for Borderlands 2 and click on “Add Selected Program”
  6. Below look for the option “Maximum Pre-rendered Frames”
  7. Set it between 2 and 4 (I’d suggest 4, it doesn’t affect latency on this game)
  8. Click on Apply and that’s literally it, that simple

AMD Users:
I don’t have an AMD GPU to write down the steps to follow, but upon a quick google search I found that you need the program RadeonPro or RadeonMod to do so.

2 Likes
Poor frames on fresh install - software issue or new gpu time?
Borderlands 2 - regular crushing
(So long, and thanks for all the fish!) #2

Moved you to the right section.

(Guajiro Pandoreño) #3

It seems to be different things for different people (Windows build version, disabling Fast Start, disabling some core sleep functions, setting PhysX to low, whatever). There are definitely other people with FPS drops out there desperate for a fix, who are purging/reinstalling card drivers and even reformatting and reinstalling Windows to no avail who would love to hear something else to try. Do tell!

1 Like
(Cgxel) #4

There it is, I said it was simple :slight_smile:

It worked on an old laptop so I’d expect it to work for the vast majority of people

(So long, and thanks for all the fish!) #5

Could you edit in the version number of the Nvidia drivers and Windows OS please? That would be helpful - thanks!

(Cgxel) #6

There :smiley:

2 Likes
(Idiosyncratic Wannabe.) #7

I’ll vouch for this being an effective fix to certain issues.

I’ve just tested it and it has improved my usual performance stutters by about 10-15 fps.

2 Likes
(Loerk) #8

I’m using a 2080ti aswell.
And i’m fairly certain that it’s not PhysX related.
I can stand blasting a wall and fill the entire screen with particles and what not without experiencing any FPS drop.
The only time I get really poor framerates is when i’m looking at “alot”.
Like for example, at the bunker tower. If I look towards thousand cuts and the game has to render everything in that scene, the frames really grind down to 40-60.
It’s very uneven, it can go from 260 fps to 40 fps in no time at all.

I got this problem before installing the UHD texture pack aswell though. So maybe it’s just that the card is not optimized well for DX9.
I don’t really see that rendering alot of buildings would chug my fps down to sub 60.

(Fusman12) #9

I also have a 2080ti and a 9700k and I have exactly the same problem. Been researching for weeks for a fix.