Borderlands 2 from THC doesn't detect any DLC anymore


(Muskatnuss) #1

This is the error message you get as you try to boot the game. I don’t know if the launch of the PSVR version affected things or not but even in the “Downloadable Content” tab, things cannot be enumerated. There is no difference in result whether the game is installed on the internal drive or an external one. I have also tried completely uninstalling the game and redownloading it from the XBOX store with the same outcome.


(Muskatnuss) #2

fyi the game was working last week just fine.


(Avaricious Old Skeleton) #3

This is just a bug, if you load the game up you’ll see that nothing has been removed. I’m guessing you have transferred this save from 360 at some point?


(Muskatnuss) #4

This isn’t “just a bug”, everything is missing. I have transferred my X360 saves the day of the launch of THC 3+ years ago I’ve extensively played with it since then. It worked last week when I last played.

I can’t even create one of the new classes altogether let alone the ones I’ve maxed out. This is 1500+ hours made completely unaccessible out of the blue.



(Avaricious Old Skeleton) #5

There is no downloadable content with THC. It’s all in one, so the store showing no DLC isn’t strange, mine does that. The other issue though, i’m not sure about.


(Is this thing on?) #6

@Muskatnuss:

You can ignore both the initial message you posted and the “Downloadable Content” one - the Handsome Collection version is the complete game as a single download, so there’s no actual additional content. Both messages are just an artifact of the game itself being ported from the 360. You’ll see that first message whenever you load up ANY level 72 character. You’ll also get those in a fully functioning version of THC-BL2.

I’m more concerned about the missing MECHROMANCER and PSYCHO categoies in your Character Select menu. It looks like your XB1 has decided that you are using the backwards compatible version of BL2 for some strange reason.

When you go into Games & Apps and view your installed games, do you have more than one entry for BL2?


(Muskatnuss) #7

My dudes, read the bloody posts / screenshots. Sorry for the tone I have played THC more than often enough to know the difference between the old error message I used to be getting and this new one. The second part is entirely different.

I was taking screenshots while you kept editing your post so it’s hard to catch up. Trying to load my Mechromancer does nothing at all because “it’s not installed”. There’s only one entry in My Games & Apps.

The first screenshot is what I am getting in game now, vs another older one with how it used to be. All of the customisation items are also missing. The Pre-Sequel saves which were also imported from the 360 work fine.

The only thing I could think of that might’ve happened is how the game talks to the server / database somehow when connecting through a bug that might’ve been introduced with the launch of the new version. It’s literally the only “Borderlands” related event that has happened in between.

When I delete my local saves, AND not allow the game to sync with the cloud saves. I am unable to access the content. That was the case with the original install and AFTER with a newly downloaded copy from XBL.



(Is this thing on?) #8

This is the thing that has me concerned. I edited my post above when I realised that the last two classes were completely missing from the Character Select dialogue. It was confusing, though, because I see the two error messages you posted all the time, and I’m pretty sure they have absolutely nothing to do with your current issue (which looks like a DRM/licence issue).

As I edited into my above post:

Also, just to clarify, are you the primary account holder on the XB1 this is installed on, and was the game purchased and/or installed under your profile?

Highly unlikely - the VR version is only on PS, and there was no update associated with this for Handsome Collection on either XB1 or PS4 (it counts as a completely different game for PS users.) Much more likely to be something local to your XB1.


(Muskatnuss) #9

I am the only owner / user of this XBOX (and by the way I tried on another XB1X I own and it’s doing the same thing) and yes I bought this on my account. I originally used the disc from the Claptrap-in-a-Box edition I had purchased from GAME in the UK but I play so much of it that eventually I purchased it digitally in order not to have to swap discs all the time.

I’ve just attempted to reinstall the game, not boot it so my saves wouldn’t sync and started it in offline mode.

All of the DLC content is missing.


(Muskatnuss) #10

Had to stream my XBOX to desktop to get this. This one is preview program, my other XB1X isn’t. Same result.


(Is this thing on?) #11

IIRC when you have your game selected in Games & Apps, there should be an option to check for updates. Does that do anything?

So I did fire up my own copy of the game (digital purchase of the HC) and that is working fine. It looks like it’s something tied to your account information and the game/system’s DRM. Are any other games acting oddly, or is it just HC-BL2?

You can file an official GBX support ticket here:

https://gearboxsoftware.zendesk.com/hc/en-us/categories/200330430-Borderlands-The-Handsome-Collection

Although it might also be worth contacting MS support, since you’re not getting full access to content you actually purchased from them.


(Muskatnuss) #12

You can’t really “force” an update check, it’s just the spinny wheel in the updates tab and that finds nothing.

I wouldn’t know if any other game is broken since I have nearly 1000 in my possession but none of the ones I normally play regularly show problems. As I said I booted the Pre-Sequel and all of my level 60 characters are present and working (played with main Athena a bit with no issue).

I opened a “GBX” ticket but it redirects you to 2K Zendesk and who knows how effective that’s going to be.


(Is this thing on?) #13

That is exactly how it works. You should get an automated reply (which usually says “meanwhile check the GBX forums”) and then a live response within 24 hours.

I just double-checked my version, and it’s the exact same version number and size on disk as yours, so all the DLC data is physically there on your disk. This is why I’m thinking it’s more likely a licence/DRM issue with your account.


(Muskatnuss) #14

One thing I haven’t tried is to reinstall offline from the disc (gotta get the Handsome Jack steelbook my preciousss off its pedestal, and see if that does anything,


(Muskatnuss) #15

Doesn’t work, the game simply crashes on startup. Will see if the 4.6GB update will arrange things. (even though still says 1.3.0.0 up top, which means the update doesn’t actually change the version number?)

edit: no.


(Is this thing on?) #16

That’s a bummer. Something is very seriously messed up there, but I have no idea what.


(Muskatnuss) #17

Apparently this is a problem on your end.


(Is this thing on?) #18

Not my end, as I’m just a volunteer moderator. And this is indeed very odd, because there has been no game update from Gearbox since what, 2015? I will, however, give a heads-up to the GBX community liaison. Paging @GeekVersusNerd

@Muskatnuss: Quick follow-up, because I just remembered something that was odd this morning. Did you get a prompt to accept the GBX terms of service at any time when launching the game during your trouble-shooting? The reason I ask is that I’ve had to do that twice recently (which I shouldn’t need to do since it had already been done). Also, did you try the suggestion in that r/xboxone thread of unlinking your XBL account in SHiFT (shift.gearboxsoftware.com) and then launching the game?


(Muskatnuss) #19

I have been given that prompt a few times yes, and I did try this (and it reminded me to update my password on there too, silver lining) but it didn’t have any effect.


(GeekVersusNerd) #20

Correct. There has been no game update, only a terms of service update which would not interfere with what you are experiencing. Whether it’s an issue on our side or that of Xbox is anyone’s guess. Sadly any potential means of troubleshooting would be out of my wheelhouse of expertise. You will need to submit at ticket to Customer Service, who hopefully have the tools to assist you. I’ll pass this thread along internally which should hopefully clue them in to where the issue might be.