Borderlands 2 No Audio - FIXED

As the title says, I am not receiving any audio on Borderlands 2. This happens only after the game is launched, and I have audio on the launcher. I am running through Steam on Windows 10. My computer is more than capable of running the game, and it has run many times with audio. I have tried the following things:

Checking the Sound Mixer, BL2 is not showing any audio output there and is not muted

Updating Audio Drivers

Unplugging headphones, and using other sound outputs

Updating Windows

Restarting PC

Reinstalling BL2

Reinstalling Steam (I’m desperate)

Validating File Integrity

Please help me, I haven’t gotten a chance to finish the game, and I’ve been really enjoying it. I don’t normally post on forums, but I don’t know what else to do.

There are multiple similar threads here that outline a number of potential causes and solutions, such as this one - an “audio enhancer” app that game with the audio card was the culprit:

Also this one - turned out to be an issue with video recording software (of all things!):

And another:

Another thing to try: if you’ve disabled the in-game cut-scene intros, try turning them back on again. You could also try navigating directly to your borderlands .exe and launch that directly rather than going through the launcher; if that works, then the launcher is doing something weird and you may want to either check its options or permanently bypass it.

I think I have tried most of those, except for the one involving nahimic 2 Audio Manager. I have an MSI laptop like it says, but I can’t seem to find Nahimic anywhere.

It’s always possible that on your system it was swapped with something else.

I would suggest first exiting every running program on your computer, then pop open the task manager to confirm that only the OS is running. Launch BL2, then check the task manager again to see what if anything got launched alongside it.

Other things that could interfere with the audio would be recording or chat software/overlays. Finally, there’s also a possibility that it’s related to the Direct X libraries. There’s a post here that talks about it, although it’s on Win 8 not 10.

If none of that fixes the problem, you can try opening a support ticket to see if they have any other suggestions.

Since plenty of other PC users are not having this problem, my guess is that it’s most likely something like a different app, conflicting settings (which may not be displaying correctly so check/uncheck every box just in case) or a missing component or wrong version driver.

1 Like

I got it to work!
I’m not sure exactly how, I just took the advice here and kind of just went through task manager, closing down anything that looked like an audio manager. I’m not sure which program was stopping it but ITS WORKING NOW!
I’m so relieved! Thank you!

I don’t actually know how to close a thread or anything, because I’m kinda new to forums.


That’s ok - we tend to leave them open in case others have a similar problem.

If you run in to the same situation again, maybe drop one thing at a time out in Task Manager so you know what actually causes the issue, then maybe you can permanently disable it (and let us know what it was!)

Editing title…

1 Like