Borderlands 2 - regular crushing

Regarding factory overclock, unless you have a reference card, most GPUs come overclocked a bit from the manufacture. I usually try setting mine to factory reference number if I can’t resolve stability issue with games. I’ve had fair share of games that had issues with the small factory overclocking on my GPUs.

FWIW, factory spec for 1080 Ti is 1480 MHz.

While I was never struggle any errors with factory clock, doubt Borderlands 2 is the game which could really bring it to me. But still who knows, so I kept this solution for later…

For now I play for a few hours and all goes fine… It doesnt mean problem is over. Sometimes game give me some long sessions, but then I just restart it and here comes the crush times. The reason of restarts for me is that the more time I play, the more and more FPS drops I get. Adono… It might be memory overflowing, GPUs heating (but not above 66 C) or anything else… But 1 thing I find is that the game using only my 4th core of CPU, is this fine for Borderlands 2?

Given that it was coded to run on a minimum system 2.4 GHz dual core/Windows XP, I’m going to go out on a limb and suggest “yes” is the answer.

For the crashing: I suspect that since the game is coded against an older graphics driver set, it’s possible that there’s some memory leak or cumulative error that comes from interacting with up-to-date drivers, and that the Windows 8 compatibility mode does the best job of pretending to be the ‘right’ drivers as far as the game engine is concerned. IIRC the last version of Windows during full support for BL2 was Windows 7?

IDK… Last time I played Borderlands was in 2012 on my PS3 and than it was first Borderlands, not second. So I never watched for this game series close enought, but in official sheets says like Windows 7 is the last support system, kek.

Also maybe my 4K (DSR) resolution mess something in game engine?

That is distinctly possible. Not sure what the maximum screen size and resolution was when the game launched, but it most certainly was not 4K!

Then I tested game with lower resolutions it was still crushes, but gived me sligtly better performance.

Plus sometimes choosing resolution different from system one might caused unstable work of some games, so I’m not sure about trying so.

For the past few months I have been playing Borderlands at 4K, and it has been fine, So I doubt it’s a resolution problem. In fact I have also dabbled with DSR before without issue. So I’d shelve issues with resolution until there really is nothing else to try.

1 Like

For now at least something concretical…

Instruction under adress 0x0000000070F66F27 tried to allow access on adress 0x0000000000000000. Memory cannot been read.

Any guesses? Seems like RAM problem to me.
I’v tried to use 3K resolution. It gave me more FPS, but during one intensive battle I get this crush.

Can you play a 5 minute session with msi afterburner going in the background, then send through the results.

This will allow us to see if something like a vram leak is taking place.

Sure, but how should I save this results?

Screenshotting the results seems the simplest way to me.

The metrics I’d be interested in are vram, system ram and maybe pagefile usage.

I don’t currently have access to my computer so unfortunately I can’t provide any detailed direction.

I did this test with Google Chrome lunched on a back and with 3K resolution. If you need all-eng screenshots I may switch the lang and repeat the tests.

Summary

Think I should conclude that BL2 just can’t work on modern Windows versions. Best option is to switch on Windows 7, but for right now I ain’t got enough free space to try it.

I don’t think you really need to do that - there’s plenty of people running on WIndows 10 (although they may well be using Windows 8 compatibility ). There are a variety of things that are known to cause issues, most of which have been covered. Are you still getting regular crashes with the Win 8 setting?

FWIW, BL2 has been running fine under Win10 for me, no Windows 8 Compatibility mode, either. Admittedly, my machine is relatively ancient at this point - 4790k, GTX 980. Only thing I’ve done is to underclock my 980’s factory overclock down to the nVidia’s spec, as I get occasional pseudo-freezing otherwise.

1 Like

The main problem now is slowly FPS “degradation”. First I lunch the game it gives me count on about 50-100 fraps which is fine, but after a hour of playing I get only 30-70 fraps and this result continue to getting worse, like my memory overflowing or something like that. Actually it doesnt even depends on graphic options, cose I tried to lower resolution more and more which is help, but only on first hours.

Also after a time playing with “bad” FPS I may get crush, as you were saw above.

Doubt this helps me with current problem.

Did you try the approach in the link posted by @Prismatic_Me (second post)? A few people have now reported that this has addressed their FPS issues. Worth a shot, anyway.

Also, you can reply to multiple people in the same post: see NEW FORUM BASICS.

There’s more information about things that affect performance here:

The comment right at the end of that post about CPU parking might explain your core usage.

Yes, I restore it to defaults right after reading it.

You know… my gaming now seems like all loaded locations I saw just never passing out of memory and just stocking there for no reason, giving me that lags and FPS drops. Idono… maybe it’s something else, but it just seems like that.

18 days old, I know but yeah, my performance hasn’t gone up in BL2 either lol.

As for crashes like that, it’s not particularly uncommon to get crashes like that in BL2, and it probably has little to do with your RAM. Some useful things you can do are to reinstall your Graphics drivers and your PhysX drivers, as that’s basically what’s going to be interacting with the game. I recall there being issues with certain networking devices but I can’t remember the specifics, so if you have drivers for those as well, reinstalling them can help.

But sometimes the game just decides to crash with some interesting error messages. If it’s not consistent, it’s safe to ignore it, really.

As for general performance issues you can look at, Microsoft’s been toying around with DirectX9 for a while now, wasn’t too long ago that only 4GB of VRAM could be used at one time. Something else you could try to help alleviate these issues is to turn off fullscreen optimizations.


It’s a bit of a misnomer, all it actually does is help Windows put the program in a pseudo fullscreen mode so it can display stuff over your window.

1 Like