Borderlands 3 not working Xbox series X

Hi guys, just upgraded to xbox series X and was under the assumption the xbox one disc should work with new console and auto upgrade game.
-Initially kept getting installation stopped.

  • uninstalled game, then wouldn’t let me reinstall had to go offline to install game from disc.
    -went back on online reinstalled all the DLCs
    -went to launch expecting to see the ‘upgrade needed’ screen, game launched to 2 seconds to the 2k screen then went back to xbox menu and greeted with “update needed” with error 0xb050033.

I’ve tried changing MAC address, power cycling you name it.

Really need helping I’ve tried so many different methods over the last week and I’m at my wits end.

Thanks in advance

Does it make a difference if you set your XBSX as your home console for your profile (ie primary account user)? (I’m assuming you’re signing in to the XBSX with the same GT as on your old console, and that you have the same region set as before).

1 Like

Hi there i just bought the game and had a similar issue. I also have an Series X. I uninstalled the whole game, then with the disc in it i went into the store. There it says you own this. Then you install it from the store. After 1 hour trying everything that finally worked. Hope it works for you too.

1 Like

As frustrating as it sounds, that sort of makes sense - I believe the disk is only used for DRM on the XBSX. Not quite what I imagined from the description provided when the updated version for the new consoles was announced, though. It seems like MS is increasingly assuming you have digital purchases only even when you buy a console with an optical drive in it…