Borderlands GOTY Enhanced - Lags terribly after 30-60 minutes of gameplay

(Klaxons) #1

So, my problem is pretty sad, cose I actually can play the game, but still need to restart it every 30-60 minutes which is not satisfying at all.

At first game goes pretty good with high FPS even during fights. But than, after some time, it starts to slow down exponentially until it reach 10-20 FPS with sound laggin’ the same way. At this point I need to make a game restart, cose all of my system start to freezing and not only the game.

I’v already tried to find information about this issue and what I found is this should be the memory leaking. Not only me who stuck on this issue in Borderlands GOTY Enchanced and should I even notice that I never saw the same problem with any other game I have (including standard version of Borderlands 1)?

Tried to launch it on Win 7 and Win 10 with different versions of video driver installed. Win 10 showed a better timing run, but still became lagging’ after a while.

Here is my PC specs:
CPU - I7 4790K
Motherboard - ASUS Hero VII
RAM - Kingston HyperX Savage 8 Gb installed
Video Card - ASUS GTX 1080 Ti Strix

(Rumplebunny) #2

I’ve also encountered some bad stuttering like how you describe after playing for an extended time. For me it clears up after a few seconds but I’m holding my breath wondering if the game will freeze or crash. :open_mouth:

I was watching some players on twitch who got early access to the game and they ran into the same thing. I’m inclined to agree there’s a memory leak happening somewhere.

(Enzeil) #3

Yeah i’m having the same problem. On a 2080ti and the game completely degrades after an hour or two to unplayable frame rates, forcing a restart of the game. And as you said it also slows my entire system down. Really unfortunate.

(Klaxons) #4

It’s still possible that this problem not even relate to any graphical software, but instead shows because of network driver or something like that. Anyway we need to wait a patch for normal fix.

(˙pǝsɹǝʌǝɹ uǝǝq sɐɥ ʎʇıʌɐɹƃ ʃɐuosɹǝd ʎW) #5

can I get every bodies build that’s got fps drops?

(Enzeil) #6

Here’s my specs. Having the same problem.

CPU - Intel i7 8086k
Mobo - ROG STRIX Z370-E
GPU - RTX 2080ti
RAM - 32gb Corsair Vengeance LPX

#7

Im getting the same issue.

Gtx 1080Ti
I7 5930k @ 4.5ghz
16gb Corsair Vengeance LPX
Asus x99 Pro usb3.1

Actually, now its saying “ran out of video memory. Exiting”

Had this problem before. Devs really need to update the physx for this game. Its a cause for a lot of peoples FPS issues and frankly, after making a UHD update, should have been addressed. I can’t tell you how many hours of my life i spent trying to fix this games physx. I almost hired someone to rewrite the dll’s to work on your gpu threads but did not have enough money to hire him. He is a pretty famous modder /app developer for games.

Anyways, im sure this will fall on deaf ears, but the squeaky wheel should get the grease, right?

(Klaxons) #8

I doubt this one is related to PhysX. Borderlands 1 and GOTY Enhanced doesn’t have much of a PhisX particles anyway, so probably it might be not a graphical issue at all. Yet, memory still leaking and this makes me sad :C

#9

Ah yeah, my bad. for some reason i thought this was BL2.

(Klaxons) #10

In BL2 and Pre-Sequel I already given up and just turn PhysX off. After all, it helps not only to FPS, but for better enemy recognition too.

(˙pǝsɹǝʌǝɹ uǝǝq sɐɥ ʎʇıʌɐɹƃ ʃɐuosɹǝd ʎW) #11

On the flip side, I’ve never had an issue with physics being on high. Bodies explode, blood spurts and parts fly.

(tarasis) #12

Same problem. Similar specs i7-4790k, Asus Z97-A mobo, 16GB Ram, Nvidia 1080ti, 2560x1080 res

Just recorded a video of what happens, this is the last 45 seconds before I quit. As you can see the stuttering (visual, audio, mouse) gets worse and worse. If I didn’t quit, the game either crashes or locks the PC up. (Doesn’t happen with other games) The last 10 seconds are absolutely horrible.

(Klaxons) #13

Yes, that’s exactly how it’s looks to me. Maybe some of the ASUS motherboard drivers cosed game to memory leaking, lol?

Anyway, I already sent the report in Gearbox tech-support. I recommend you to do the same. The more info they get, the quicker they could fix the problem.

(Sizelove1) #14

You need to set up a cached memory dump. Search YouTube

(Klaxons) #15

deleted

My bad. Not caught the point.

#16

Been having similar issues as well. Game plays extremely well and fluid and then after a good bit, has to be at least an hour or so it seems, all of a sudden it drops from 60fps down to around like 5… to the point where I’m just waiting for the game to crash. But it never does, and it actually goes back to normal if I just wait it out. Seems to take around 15-20 seconds or so and god forbid I’m in a heavy fight… lol

1 Like
(kills Craw with Knoxx's Gold) #17

I experienced this for the first time yesterday…waited it out and it returned to normal after 30 seconds or so.

I’m also running an ASUS board, but a cheap one…cant remember the chipset. No-frills skylake.

(Ask me about Jack Monkey Squat!) #18

Chiming in to say that I also have an Asus board (z97-A USB 3.1); I spent about four hours in-game yesterday afternoon and saw zero lag.

(Ibslice) #19

I also have had that problem with a 2700x and 2080ti
I found it was the Xbox One wireless controller.
There was a 100 to 200 fps difference with it plugged in compared to using the mouse/keyboard.
Same issue with Borderlands 2 as well.

(Harvester687) #20

Well, I followed the nvidia control panel step listed here. The lag is still there but the horrible stuttering has stopped for the time being.

1 Like