Borderlands GOTY Enhanced - Lags terribly after 30-60 minutes of gameplay

Will try, but I still think this does not suppress the problem in game code.

Not for me, but thanks. Also tried dropping my res from 2560x1080 to 1920x1080 because I noticed that at one point some of the red text was poking in the side of the screen, but it didn’t help.

I don’t think that updating drivers and tweaking graphics settings is expected to do anything for memory leak problem. Other than turning off background software for decreasing ram usage, so it takes longer for leak to build up to point where it overloads RAM.

Could you elaborate on this? Which red text?

I’ve been getting this problem myself a couple of times, looks exactly like the video you linked.
Dunno if mobos are the still the suspected culprit but mine is an MSI Z370-A PRO, housing an Intel Core i5 8600K. Currently running 2560 as well but I think I can live without that if it helps.

Look on the left hand side, you can just see the edge of “wave”. I suspect its the trick of moving an asset out of screen bounds (because ultrawide wasn’t a thing) rather than the costly destroy and recreate it.

So I decided to try a lower res just to see if it made any difference, but nope.

No, likely not, but after 55 hours of playing (and restarting each hour / or after the odd crash) I’m up for trying anything to see if I can delay the problem.

I’ve tried stopping background processes, extra apps and more but not a single thing has made a difference.

1 Like

I found a thing. Idk if it’ll help, but it’s interesting.

Indeed. Mmm … Curious if there is any improvement if running at 1280x720. I guess I will give it a try soon for curiosity’s sake

No problems running BL Enhanced on dual core. (Pentium G3258) So basically I interpret it as game running most demanding processes on just a single thread. In other words, the processes split on multiple cores are bottlenecked by performance of single threaded processes.

just like BL2, actually.

1 Like

Thanks. I’ll experiment a bit more with the settings but the problem hasn’t actually recurred, so…
For me it’s only happened 2-3 times so far but I would prefer not to have it suddenly jump me again in the thick of combat far into a mission.

Was playing the Dr Ned DLC yesterday, even on a freshly restarted game I was getting horrendous frame drops all over it, particularly on the stretch to the secret entrance. What was rock solid 60fps on the main game, or in Moxxi DLC, was dropping to 40 and 20 fps.

Tried setting priority of the game exe to high but that didn’t help.

– Edit –

Knoxx DLC seems worse. Game crashed faster than normal, only about 30 minutes.

Be spending days with a 2k support person trying to get to the bottom of this. Being trying everything under the sun. Seems to happen faster when running Borderless Windowed mode. (30-40 minutes, rather than 60-70 when fullscreen)

Game appears to be causing latency issues on my system, which is causing the audio hitching / framerate stuttering.

Borderlands 2 and the Pre-Sequel don’t appear to cause the same issue.

TS is now picking up the contact. I will try to find out what it could help about this issue.

Okay I don’t know if this was already mentioned, but I had the same issue with the enhanced version.
My game was bottle necking through only one core, while my system has 8 hyper threaded ones.
I was looking on the internet and found this trick
Run msconfig>boot>advanced options and select maximum cores you have in drop down menu > apply setting and restart you PC…
I run some tests and it appears to be working, no more dropped frames after playing for 3 hours, still need more tests obviously but this is a start…

2 Likes

It didn’t fixed the problem to me. Seems it’s some kind of different issues.

I haven’t had a chance to make very long runs with that advanced boot option, but today I noticed that after only two hours game started to lag again, and according to task manager Borderlands GOTY uses only one core again.
I have loaded the original game and run it on max settings and all cores were used.
So there is something in the remaster that makes it run with only 1-2 cores.

Well, this is interesting. After the latest major Windows 10 update installed, the ‘memory leak’ problem seems to have vanished. The update was the only thing that’s changed; I have not updated video drivers and it doesn’t look like Steam snuck in an update to Borderlands itself. :wink:

Used to be, I would get those stutters and slowdowns after a while. It seemed to trigger more often when I travelled back and forth between a few different maps, it would start to ‘gum up’. I was especially able to reliably trigger it while farming the gift shop; after a few quit/save-reloads, it would start to slow down and stutter. It appears to be gone now.

Not to get anyone’s hope up though; if I get those slowdowns later on on a future play session I’ll update. But I’m guessing some possible changes/tweaks/fixes to how Windows handles video or system memory could be what’s at work here.

1 Like

What update number are you talking about?
I’ve played remaster today just to check if the lag has been fixed and it is still very much laging after 1,5 hours or so…

The 1903 update, it’s been out for a little while but it didn’t roll to my PC until a couple days ago.

Update: Yeah nevermind, I had the time to do some serious Craw/armory farming and still got the slowdown stutters at the expected times. Oh well!

1 Like