Browser opens every time I start Wonderlands (specific to Epic Games)

This is starting to really get on my nerves. Every time I open Tiny Tina’s Wonderlands, a web browser opens up on top of the game and demands that I allow Epic to connect my account to the game (I realize this is an Epic issue, but they don’t seem to have a forum that I can find for anything other than the Unreal Engine, so…). Seriously, it’s 2022 and I know I’ve signed away my privacy rights to any and every online company already. Why in the world can they not remember that I already granted it access? I can’t play the game without granting access anyway, so what exactly is the point? AAAARGH. If someone from Gearbox would contact Epic about this problem, it would save me some heartburn.

PS: Please don’t turn this into a hate thread about Epic. I get it that the platform is not as user friendly as Steam’s, but my understanding is that they take substantially less money from sales than Steam does, giving more to the developers. I highly appreciate that, so I prefer to buy from them when I can. And this is really the only issue I’ve ever had, other than their lack of forums/reviews.

4 Likes

Edit: Nevermind, lol, it was working for a bit but now that the servers are having issues it seems to pop back up now for me. Probably was just a coincidence.

Which web browser are you using? it seems like I get this issue if I have an opera gx window open, but if I close it, then it does not popup.

Might just be some strange interaction with the browser, though it should still be fixed either way lol.

Chrome here

That’s interesting you mention the server issues, though…every time I’ve played I’ve had that problem as well. I keep getting notifications that I’ve lost the connection to the Shift server, then a few seconds later, it connects again. Could be somehow related?

Finally, someone else who is having this exact same problem.

I’m emailing back and forth with Epic Games and so far no solution, but I’ll let you know if something works.

I’m using Opera for my browser. I feel like this is definitely a connection issue between websites, because I’m also getting those SHIFT error messages, AND, my SHIFT login says I need to verify my email, and when I click the link to verify, it says it’s already verified, but then still won’t let me log in.

All these security and marketing measures are so half-baked. The irony is that there are probably tons of people playing this game illegally, where it’s been cracked to avoid all this nonsense.

There was a thread elsewhere in which someone shared from the SHIFT Status Twitter that they were having server problems. Last I saw, there was a fix being rolled out, but it was being done by region and you needed to restart your game to force a new connection.

The latest post from 1 hour ago implies that they’re experiencing further similar issues. I would recommend bookmarking that link so you can check it any time SHIFT seems to be acting up.

1 Like

Thanks. I rarely buy games at launch because they always have rollout issues, so I may just put the game aside and follow their Status Twitter to see when they get it remedied.

This is the first game I’ve had to use the Epic Launcher on (exclusivity and all), so this kind of interconnectivity was bound to bring about some setbacks.

I also have the webpage popup every time.

I do not believe its related to the server/connection to shift issues mentioned on the twitter post. My friends and I ran into the actual server/connection issues in-game where you’re unable to connect to shift or join fellow friends etc.

I work in IT and I have a feeling its probably related to the web browser permissions or epic games store desktop app permissions. Such as its not saving any cache responses of previous acceptances.

I’m also using Google Chrome which I see someone above mentioned they were using too.
Is anyone else also happening to be running Ad Block Pro or some form of Ad Block plugin apart of chrome?

1 Like

Epic Games has put this in the hands of several different reps, all of which are asking me redundant questions, and asking for screenshots of things I’ve sent ad nauseum. After re-sending a shot of my system, which meets recommended requirements, they said “disable your vpn, thanks!”…and I’m not using a VPN.

I didn’t have this problem the first time I played, and I actually got it working one other time, sadly logging about 2.5 hours, but I’m pushing for a refund. I’ll play this on Steam. Their refund policy is just as absurd, but at least their games launch.

To be clear, the support from Epic has been completely tone-deaf.

Same issue here using Chrome (PC, windows 11, DX11) and getting the constant disconnecting to the servers and connecting again. I’ve noticed it most when I defeat a bos, pick up rare loot or transmit between maps. I don’t think this is anything new as I get the same disconnecting and connecting issues while playing BL3 that sometimes causes a game crash or freeze. I’ve tried to check my log file to see whats shutting the game down but the only entry is “Request to close.”

I’m also having the issue of a browser window opening with the Allow/Deny prompt every time I launch the game.

I’ve tried the following troubleshooting steps to no avail.

  1. Completely disabling my Pi-hole server and configuring the network to use public DNS.
  2. Three different browsers, setting each as Windows default (FF, Edge, Chrome).
  3. Verifying game files.
  4. Running Wonderlands.exe as administrator.
  5. Three different install locations for TTW: a) My normal path on a dedicated NVMe drive. b) The same parent folder as Epic Launcher, which is a custom path on the system drive (another NVMe). c) The default install path for Epic Games in Program Files (also on the system drive).

At this point I’m out of ideas. I’ve never once been able to launch the game without getting a browser prompt.

For reference, I’m running Win 10 Pro 21H1.

Add me to the group, opera and chrome… no solution…

Ditto for me with Firefox, so not Chrome specific.

Edge browser and same issue. I believe this is related to their weird SHIFT / EPIC user duality / connection to the game that I am guessing is a “thing” for cross platform play. I don’t think it’s browser specific but certainly could be due to some browser security setting default they did not take into account when testing.

I’m not seeing this as a deal-breaker that makes me want a refund (I’m guessing the Steam version of the game will have the same issue unless they address it from the SHIFT / EPIC user side), but it is highly annoying and the fact that my son playing on another PC on our same network does NOT see these web page popups at start is just sketchy as hell…

I’m also having the same issue. I’m assuming it’s not my antivirus or ccleaner on the ox because others are having the same issue. I’m hoping there’s a fix soon because it’s getting exhausting especially if the game decides to lock up or freeze.

Having the same issue with Chrome. Haven’t had much connection issues since Monday so I don’t think its a server issue. Its not a deal breaker for me as I’m having a blast with the game but its just annoying to deal with. Hopefully they fix it soon.

Same issue here I’m using Chrome.

Same here, using FF .

So, after so much testing, I have found a consistent fix for me. If I unplug my old, wired xbox controller, my browser doesn’t open and the game logs in normally. I don’t know if the issue is just my controller or any USB, but check those.

I am not sure why it is making a difference, but if the controller is plugged in, I have to connect my epic account. If the controller is unplugged, browser doesn’t open. If a random video I watched hadn’t mentioned USB devices, I would not have even thought to check.

3 Likes

It would be a real pain if USB headsets and external drives also turned out to trigger this issue.

My wife has been having the same issue, so I decided to try this after reading your post. Worked like a charm! No idea why, but unplugging the controller immediately solved the problem. Thank you!

1 Like