[Bug] Going Rogue main story quest - Shooting rogue sight mark - Can't progress game story

For some reason, the Rogue Sight revolver no longer works on the Rogue sight marks.
There was nothing spectacular that happened to trigger this bug. It just simply doesn’t work anymore.

Currently on Ambermine map.
Let me know what kind of extra information I can give to resolve this issue.
I already tried exiting the game, and coming back.
Not sure what other actions I could take, any help would be appreciated.

Sadly having the same issue and stuck here for days…

Sorry I mean no offense but that screenshot doesn’t look like you are looking through the scope; I don’t remember seeing the entire HUD, just did this about an hour ago.

I could be mistaken.

If that’s not the issue, sometimes switching difficulty helps. Grasping at straws, sorry :neutral_face:

The scope is quite visible, the Jakob’s golden corsair is visible. Furthermore, the circle target is lit up in red. Hence, an indication that i’m looking through the scope, cause otherwise, the target wont be highlighted the way it shows in the screenshot.

Anyway, I found a quick fix. I just had to leave the map, and go back to it.
Exiting the game and coming back doesn’t fix it.

Maybe this is precisely the bug, since I recall that the HUD would disappear while on scope.

Solution: Leave the map, and come back to it again.
It fixed it for me, exiting the game and coming back does not fix it.

1 Like

Excellent, glad you got it resolved

I left map and came back, still not working.