Bug Reports and Feature Request

If you have a bug please submit it at http://2kgam.es/BL3Support

this article was created before the known existence of the above support site.

Please use this place to report bugs found while playing with the game. please note what system you are playing (and version when that actually becomes applicable) provide as much technical context as you can. this will make it much easier for the dev team to actually resolve our issues as they arise. (I am not a developer of this game and tried to find the official place to put bug reports, after finding nothing I am making this forum)

Please use this space to review previously reported bugs seen since the game has been released. And hey, maybe you’ll be lucky enough to find that someone has fond a solution to it here.

Also if you cant help but ask for more stuff (little things) here seems a decent place for that as well.

have fun with your new meat puppets!

edit: on 9/18 found the actual support page, redirected traffic to the companies website.

8 Likes

Known Bugs (PC) from first session of the game:

Unlocking new collectible, leaves phantom image of the part of the image that undergoes a movement animation, this image stays until a refresh is forced by scrolling the now empty slot out of view and back into view.

When completing a global challenge i.e. “Sell 5 guns” the tool-tip indicates to hold tab to get to the screen for the challenge list. this currently just points to the general map screen (I’m assuming this is an internally known temp fix until you get the actual screen completed but still worth noting)

Multiplayer session (internet) when given the tutorial to setup a car for the first time if a player other than player 1 (Host) completes the tutorial before player 1 attempts it. Player 1 will not have the option to spawn a vehicle until they skip the tutorial (they are unable to complete the tutorial they must skip it) the tutorial will ask to deploy however pressing Q does nothing and the only option is tab. Also during this time tab will not go back a screen only exit the interface entirely.

Also during my session the other players made a complaint about the game forgetting grenades or bullets that should have been fired. I cannot verify since I was host, but thought it might be worth mentioning.

Feature request (If I may) since we have 1 click purchase ammunition, can we get 1 click sell junk? skip-able cut scenes? exiting the game does not mention that progress will be saved as it has on previous BL games, consider adding that.

Dev’s can we get a formal bug report / feature request page? I’m honestly surprised I was unable to find an official place you expected this to end up.

1 Like

PC gamer here, ive noticed that in the first area ‘Covenant Pass’ if you zoom out the map there are 4 purple vehicles shown on the top right corner with various test names. Is this intended?

1 Like

Edit: Disable “FidelityFX sharpening” if you have an ultrawide monitor to avoid the below issue in the picture.

I started the game for the first time. Once the Opening cinematic went from the drawn art to the in game graphics cinematic type video it got squashed into a glitched 4:3 resolution and seemed to be cutting off part of the video.

I’m thoroughly not impressed having to troubleshoot a brand new game in 2019 AT LAUNCH!!!.. :sob: something as simple as a freaking opening cinematic shouldn’t be having problems.

Windows 10 (Latest updates)
i7-4790
GTX 1080
16GB RAM
Monitor: 2560x1080

3 Likes

I’m having a issue to where I change my resolution, but the second I restart the game it doesn’t save it. It acts like it’s loading it until after claptrap it changes

I got 2 legendaries as rewards for what I’m assuming was pre order bonuses and the have no stats or title. 0 damage 0 magazine size 100% accuracy /handling. Echo device glitching so I can’t escape and am walking around with it open and unable to turn. Ridiculous for a game that was delayed for the big patches

7 Likes

Whenever I have my crosshair over an enemy the health bar for the enemy appears in the middle of my screen rather then above

1 Like

In my first play through this evening I got to a point where I could not leave sanctuary 3 through fast travel or drop pod. I tried everything, cycling through planets to restarting my computer. This breaks a character that I have already put 7 hours into. Game breaking bug.

8 Likes

I am amputated and have since almost 20 years back always used the right side of the keyboard, arrow keys/numpad/insert/delete/home etc.

Minor feature request would be to expose UI keybinds as they are hardcoded and I have to lean quite far to reach the keys, for now I can at least use the mouse, though mouse and UI seem to be a bit wonky atm and I have to double click sometimes for it to register.

5 Likes

I am at Cut Following mission. Once you defeat the boss he is supposed to drop the “vault map” which he did and i picked up. yet, it did not continue the story mission so I am now stuck on the mission. I can not find the map anywhere and tried to run through trying to find it.
Not sure if its a small bug or not.

2 Likes

PC here. Can’t sign in my SHiFT account (sign in easily in browser but in game it says that e-mail or password is wrong (they are NOT). also sound glitches after doing anything in menu (both game menu and ECHO menu)

3 Likes

Playing coop on ps4, my brother play as Moze. He installed the second gun for me to ride his robot but when i do, the camera shift to 3rd person view making it impossible to aim at anything as all i can see is my own back. Even worst while zooming. As others said, menu is a bit laggy. I never received my maliwan smg from the vip program even though i did everything. And about the rewards (vip and preorder/deluxe) why give us lvl 10 legendary weapons and grenade mods that have worst stats than lvl 7 rare gears. Make me regrets my purchase. Im happy with the game overall. I’ve been waiting a long time for this but the rewards for vip and super deluxe suck. (aside from the season pass of course)

1 Like

EDIT: In reference to cutscreen issues.
I had this problem as well. I read elsewhere that it can be fixed by disabling FidelityFX in the visuals menu. I think this is a problem with ultra-wide resolutions.

I have two issues, neither of which are game-breaking but both are annoying.

  1. Every time I start the game, the internal rendering resolution is lower than my actual settings. I have it configured to run at 4K with 75% scaling but it looks like it’s rendering at no more than 1080p when I start the game. Moreover, the scaling is really poor; angles have incredibly jagged stair-stepping and the image is very blurry. A quick check of the settings shows that nothing has changed since the last session (still 4K, 75%). To get it rendering correctly, I have to switch resolution and then back again.

  2. The map snaps to fast travel points completely at random while panning around it. I understand snapping to a PoI when within a few pixels of it, but this is happening when I’m centered on the opposite side of the map. I’m also well aware that the cycle waypoints function exists; this is not that. Super annoying to have to repeatedly move back to where you were on the map because you got snapped to the opposite end of it.

5 Likes

I have the problem of pre-order legionaries having no stat/zero stats, completely unusable.

Separately, each time I start up the game using DX12 I have to watch Claptrap dance for 4-5 min. I have a 1080TI & I7-7700k with a slight overclock. I thought it was only the next time after setting DX12?

2 Likes

PS4 with Splitscreen:

Inventory management chaos, the pictures, names and stats get mixed up often. Resetting the interface helps.
Subtitles in splitscreen are tiny at first, you can change it in the settings. Everything is tiny and hard to read in general in splitscreen mode, would love to increase the general UI size.
Had a crash once. Not sure why…
Performance issues on PS4 with splitscreen on, its understandable i guess, but i hope they improve performance or let us change more visual settings. I hate consoles, i only moved to PS4 because of EGS.

2 Likes

Ps4 player
I’ve noticed that if you edit your controls from the classic settings you are unable to map any of the misc (while walking) buttons. Though I’m fine with not pinging as I rather be able to swap weapons using the d pad, my playgroup is getting a bit annoyed with me not pinging loot.

I can’t imagine this is intended as I think the area would be greyed out right? Are anyone on the other consoles experiencing the same issue?

On PC, the Push-To-Talk key is permanently bound to “T”. I cannot rebind PTT to any other key, nor can I bind any function to “T” and have it work correctly. Quite frustrating for someone who has a hard time with default controls.

1 Like

PC- Add an option to change ONLY subtitles language in game please.

Platform is PC:
While in Photomode you are unable to emote. I changed the keybindings thinking that was the issue and I still could not emote. It only effects the person in photomode, so if you’re playing co-op, your partner can emote but you can’t.