Bugged side mission: Wildlife Conservation [SOLVED]

A quest item is stuck on an unreachable ledge, unable to progress the quest.


Unless you can grenade-jump up there, you’ll probably need to save-quit/restart.

Problem is, nothing works, I’ve save-quit, I’ve restarted, and I’ve tried grenade jumping (although I’m not too good at that) and nothing seems to work.

May have to wait for a patch?

Absolutely no way up any of those rocks even using the mantling move?

No way at all, trying to spam jump up them now

After spending way to long using Amara to glitch up there I can confirm that it’s an Echo Log and not the Dynamite


Really? Dang, been trying to get up there all this time for nothing

1 Like

And now I want to know what’s on the echo log… Rocket jumping, anyone?

1 Like

rocket jumping doesnt work you have to use amaras downfall ability on a few rocks you are able to jump on near the door you are supposed to blow up, then there is a ledge to your right you need to spam jump after using your action skill then do it again to get it the audio log about, you can then run all the way back to the other side of the door but no enemy’s will spawn and you will end up getting stuck


That’s not the bomb it’s a holotape

the only reason I know it’s a holotape cuz I found a jump path up there I cannot do this quest myself still trying to figure it out band behind the door I found a way around

1 Like

My last dynamite was behind the last steel beam to the right of the door on the left.

Well…I don’t want to spoil it. Just know it’s kind of depressing.

I’ll get there eventually.

It’s not bugged, the last one is behind a beam, it was pretty unnoticable, also sorry for the bad quality, Im playing on my xboner uno.


You are a lifesaver for that picture. Thank you!

No worries. Took me ages to find it too :stuck_out_tongue:

You are the real hero, my dude.

1 Like

The thing on the ledge is a holotape, you can pick it up on the way out after the mission. The pic below shows the ridiculously unfindable explosives.