Bugged Troy Fight Cannot progress

Not able to start the Troy fight. They just stay locked in the purple orbs. Ive tried shooting them nothing . I tried completing all side missions and everything up til that point but still no progress. Even a few side misions are Blocked because the Troy Fight is not completed!

1 Like

I would exit out of the game and restart.

tried many many times. even did a cache reset

You may have to join somebody else’s game to complete it.

oh ive done that many times. but for some reason it wont advance

When you join another players game to fight Troy, the mission won’t progress?

if I join someone else it will but doesnt count for myself.

Have you tried dying at that point, and seeing if it respawns the boss battle?

yes ive jumped off the side and it respawns me at the top. just to jump back down and still doesnt start. few of my friends said this one is a strange one. I put a ticket into Epic and they actually stopped replying lol

So… the cutscene won’t trigger when you drop down, but only with you playing solo?

Have you tried creating a new character with a guest acct on your system, and have them join before you drop down?

Have you fought Troy with a diff character on that system?

Have you tried offline and online?

Have you tried reinstalling the game?

I’m trying to determine if the problem is your install, or your save.

Same here. Happened to me on PC.
I have tried all the method mentioned above but still cannot get it to work.