Bugs and such we find

So I’d like to start a bug thread since I seem to be having one that is also in HWRM. When I click on menus between missions and in the menu I have to actually click twice, it is like the first click is ignored for every button but exit. So post what you have found so we can get a list going of what issues there are to be addressed.

1 Like

Thanks @Alpha_1!

We’ll make sure to keep an eye out here and pass everyone’s findings on to the team.

I’m unable to complete the Kalash Site mission because though there are no more enemies on the map the last objective (kill all remaining forces) is still considered incomplete. In one of my playthroughs I did find the final enemy, but I was unable to assign an attack order on that unit. I’ve replayed it three times, same issue every time. I still plan on seeing if changing difficulty replicates the issue.

Apparently the multiplayer is region locked

edit: i wish i could change how far my game looks for other matchs.

Region filtering is set to ‘far’ according to the devs. I did get quite a bit of lag when I switched my region to US but UK seemed a lot better. I’ll try again tonight setting my region back to local and see if I get any games.

Global chat though is not region locked, that I know at least.

There seems to be a performance bug in the game that is resulting in widely varying performance on different systems with no relation to actual specs.

For example my system is an i7 6700, 8GB GTX, 980 Ti and I’m seeing framerate plummet to ~30fps while others on older laptops are seeing smoother performance.

Would be really worth investigating I think…

now I have more issues, I can’t see any matches in the multi-player lobby even I do change the download region.

Are you sure there are any games up?

Nope, just blank, global chat works, I just can’t see any matches at all.
I’m in australia if that helps.

Just a follow-up to the Kalash Site mission: I’ve determined that destroying the enemy Production Cruiser prior to the enemy attack on Kalash Site itself can recreate this bug. If the Production Cruiser has produced units but is destroyed before the unit group can be deployed to the wreckage area close-by, those units remain in a holding state. In this holding state the enemy units cannot be attacked, making the mission impossible to complete. I’m curious if anyone else can recreate this bug.

I’m having an issue with the guard command. I noticed in the campaign that some units just stop and won’t do anything until i re-command them to guard.

For example: I like to group 2 support cruisers and have all my units guard them so they at least move at the same speed until i get in range of enemies. Then i run into a small force that I don’t need to micro anyone to attack and once they are destroyed some of my own units just sit there.

It’s as if the formation my units are in around the guarded unit don’t want to let the others back in until i re-issue the command.

I checked last night as a test, switched my DL region to my city. Couldn’t find a match on automatch nor see any games up in the lobby.

I then switched to the UK DL region in steam and got 1v1 automatches relatively quickly and could see a match in the public list.

2v2 on Dunes, are carriers suppose to be able to get up here? He went full power in sensors and weapons and just rained death from the top on anything we sent at him.


Not really a ‘bug’ but kind of is, When the carrier’s parked up against a wall the built vehicles tend to jump out fast and high. And then this happens.


They get stuck ontop of un-navigable terrain until the mission ends. Whoops! Was cool to see them make huge jumps up there though.

I just ran into the bug on the Kalash Site mission where the game says I need to destroy all Gaalsien units to proceed, but I have scoured the map and there aren’t any at all. I killed 3 Production Cruisers during the mission, one before I was ever instructed to clean out the units, and it was replaced by another one before too long. Once I was told to clean up all the units, I went around and killed it and the other one that appeared as well as sweeping the entire map with LAVs and Recon Probes. No more enemy units remained on the map, yet I can’t progress.

I have the same issue, but in my case there is a “untargetable” unit on one of the hills, tried planes and tanks but still cant attack the unit. I really don want to play the level from the start.

Plz fix :expressionless:

I dont know if this can be duplicated, but during a couple of the campaign cutscenes the Kapisi would “drop from the sky” and slam into the ground. Had no effect on game play, but i wish i had fraps on when this happened, because its funny! In one scene the Kapisi was flipped to its side at the start of the scene. Then flipped upright, and smacked the ground.

I don’t know if this is a bug but in skirmish mode the artillery cruiser and the siege cruiser don’t fire the main missile weapon when enemy is in range. but in campaign both units rain missiles automatically.

Flying Kapisi

Exact same bug here. Played it twice, but both times I destroyed the Production Cruiser earlier in the mission. I will try your solution later today. Thanks for figuring that out!