Campaign Skipping via Online Matchmaking (Bug?)

I was doing solo all the way up to right after you go into Atlas HQ and I figured I would try to find a group to do my quests with (get some help and all that) but, I joined into a group that was like 2-3 main quests ahead of me (Rescuing Hammerlock main quest) and now I can’t go back and do the main quest I was on and it is kind of frustrating because I wanted to play through the whole campaign to see everything. 8 hours invested into one character and now, it just feels like kind of a waste of time. Idk if there’s a way to go back and do those quests or maybe I’m just screwed and have to make a whole new character to see that quest.

7 Likes

I exited out and went back into my game, then traveled back to my last location and was able to continue with my story. I didn’t do any quests though with the matchmaking group, once I realized I was no longer in my own campaign, I just went back to my own solo campaign mission

I’ve had the same issue. It’s also potentially game breaking.

I just got off the drop pod into the 2nd planet (last mission was finding the source of the distress signal), and decided to play multiplayer. I joined a group, but they were missions ahead of me (finding Rhys). I exited the multiplayer game because I didn’t want to skip the story. When I started back on my character solo the mission was still on finding Rhys. I fast traveled back to the drop pod where I left off and preceded through that part of the map and got to the tunnel but I couldn’t proceed forward because the tunnel was locked with no characters around or anything to open it (potential game breaker).

Now, repeatedly joining and exiting multiplayer games has resulted in me further along the storyline (with no idea what happened), and I’d somehow acquired the wheel vehicle out of nowhere, but the part where I was stuck in the tunnel part had got fixed? I could go through it now…
I don’t know, I feel that this main character I diligently played got completely messed up and now I have to start over.
So I’ll just go through the story completely solo on a different character. I was most likely going to make a run as a different character anyways.

4 Likes

This is the worst campaign multiplayer matchmaking I have ever experienced…

————————————————
I just finished campaign 3 .
Next would have been 4
———————————————-/
1)
First time I joined an random multiplayer campaign I was thrown in a campaign 5 or 6 .
The matchmaking system just skipped campaign 4 and thought that it would be a time saver for me … haha.
I left multiplayer immediately!

2nd time I tried campaign matchmaking.
Gearbox threw me in the right session, the campaign 4 …
BUT the campaign 4 session was nearly at the end …I didn’t have enough time to leave… so I finished the campaign 4 without playing more than 15 seconds of it. Wow.

Damn thing is:
In single player the campaign 4 is now marked as finished and I cannot play it any more!!!

I lost the whole campaign 4 , cannot play this part of the story anymore , except I am starting all over again with a new character .

Gearbox … is that what you really wanted???

3 Likes

I’ve had the same issue. I think it skipped like 5 story missions for me. Was wondering if there would be a way to replay main story missions? The game gave me an option to skip missions I’ve already completed, but I selected no each tine, and it went ahead and skipped it anyway. Pretty irritating but at least it isn’t game breaking, I can still proceed along the storyline.

3 Likes

Same. I joined my daughter in multiplayer for just one mission, realized she was hours ahead of me, and exited

However upon resuming my game it now had me at the same part of the story that she was, and marked everything up to that “completed”. I missed out on the entire Athenas campaign. Going there now there is literally nothing for me to do but a single sidequest. I totally missed out on it as well as a large part of the Rhys/Atlas campaign. How did this pass testing as a finished product???

2 Likes

This exactly happened to me I joined matchmaking for like 5 seconds and got timeout and they must have been missions ahead of me now my solo game is ruined as I cant proceed through the tunnel. I’m afraid to try to matchmaker again because I know it will skip more missions, so stupid that it is like that there should be a warning or something.

2 Likes

Mine was a little different, I was playing campaign with friends during the jakobs homeworld and beat the game, now when i go into solo im back where I left off and have to do it all over again?

5 Likes

This just happened to me too. I was loving my character. I’m heartbroken. It does indeed feel like the playthrough is now wasted.

1 Like

This just happened to me. I was level 11, just at the start of the Rhys/Atlas campaign on Prometheus. Decided to try matchmaking and it joined me with a level 16 game fighting what I think is the last boss of Athenas. Sure enough, everything is marked as completed and I’ve missed the entirety of both campaigns because I joined someone else’s game for <10 minutes.

Really disappointed. Kinda want to restart but not sure I’m up for playing through again. Might have killed the game for me.

yep, same issue has happened with me,
played solo all the way up to where you drop onto the 3rd planet (chapter 6 i think?) and then thought hell lets try matchmaking with a group… after subsequently being thrown into 3 or 4 groups that were just sat in sanctuary doing bugger all (At no point did we do ANY missions, visit any areas, ANYTHING!) I logged back out and resumed solo… only to find i was now starting chapter 7… and it was asking me to go to a different planet (a previously visited one infact) which is what sparked me to realise as i KNEW i had just got onto 3rd planet and hadn’t done anything there yet.

I then thought i’d try to rejoin a few more online games in the hope it would throw me into someones game who was starting chapter 6… nope… instead then progressed me FURTHER, threw me into a game on chapter 8 (recommended lvl 22, i was lvl 15 at the time…) and so now im stuck missing out on both chapter 6 and chapter 7 campaign… hoping they fix this… if not, im relying on a friend who is currently behind me in the story to catch up, i’ve essentially told him look when you end up visiting the 3rd planet (avoiding spoilers!) to let me know so i can play through with him. hope this works, or better still - hope they fix this issue as it is gamebreaking.

This is exactly what happened to me. I tried to fix by joining other games and got shifted further and further into the game.

I don’t want to start over at level 17 but… That might be the best option? This sucks! Why would they design it so that we have to solo our first playthrough???

Hi all - I made a ticket for this issue at https://gearboxsoftware.zendesk.com/hc/en-us and suggest you all do too.

I REALLY want to start over but am afraid of losing all of the bonus content I bought with the $100 package. This is BS.

4 Likes

Bumpity. This just happened to me as well. Finished the Temple, tried multiplayer campaign, now my single player game defaults to that same multiplayer level, way ahead of where I should be. Please please tell me there is a way to fix this. At level 17, the prospect of starting over is horrifying.

1 Like

@CapnGeiger & Danielje… last night i did what i proposed to do above and waited for my friend to catch up to the point where i was (chapter 6) and played through this as well as a few more chapters in his game, for a temporary work around. it worked, i was able to play the missions with him. what i think has happened now though is… which is REALLY strange… we went beyond the point where i had been skipped to (chapter 8) and now my progress DIDNT save in line with the progress we made in his. i think in his game we got to chapter 9 or 10, now in my solo play through im STILL on chapter 8. tell me how that works because i have no idea! so now im entirely reliant on him for main story progression unless i now replay the missions solo , which isnt end of the world again but frustrating none-the-less. I think they need to implement a simple question when ever you begin to progress your main story missions in someone elses game; that warns you for example:

*Warning; you are about to start Chapter X of the main story mission in this multiplayer game, you have only progressed to Chapter Y in your current playthrough. Do you wish for progress made within this game to count torwards your solo-play progression? If so, you may miss out Chapters: X, Y & Z"
Choices:
YES - Yes, I don’t mind my personal progress being altered to reflect the progress made within this game
NO - No, keep my personal story mission progress separate to this multiplayer experience

etc etc… this could be done for progress that jumps you BACKWARDS and progress that jumps your FORWARDS.

2 Likes

If I may make a suggestion for upstairs, matching options:

  • your level (non-story modes only).
  • same mission progress (any level). Risk of folks weedwhacking everything for you.
  • same mission progress (your level) so folks don’t go and completely weedwhack everything before you get there.

Should solve most everything. And it don’t yank folks ahead of the story, I think.

2 Likes

I have submitted a ticket as well. I have skipped so many missions on my Solo play because I play with my friend who is ahead of me. I really wanted to 100% my run but now I’m skipping things and have no clue what is happening in the story.

I’ve heard similar accounts from others who have this bug. Trying to go back and play up to where the game thinks you are from the multiplayer campaign will break your quests something fierce. Supposedly, if you get far enough ahead in the main story, teleporting back to where you should be will cause the game to attempt playing all of the ‘missed’ audio at the same time, resulting in a Crash To Desktop.

I’ve submitted tickets both here and through the Epic Launcher. Hopefully we’ll have more information soon. I know for sure that I don’t have the heart to replay 6+ hours, which would mean trying to get a refund processed :confused:

ok now- wow iam having the same issue- i jumped in a ‘campaign’ co-op at level 18(after leaving atlas)…and now with a few groups iam level 27…i havent hit the third planet. also, i missed the intro to most of the characters tina, brick, marchai- this system is a major fail.

they should have specific chapter co-op. vermintide 2 does it this way.

I dont mind jumping in the middle of a run- but dam cant even do my own solo run ,nor do missions i have missed.

iam not alone on this…

I played on proving ground Matchmaking.

A lvl 22 dude popped and had tokens enabled… I left the game.

Short story