Cannot load Karos Graveyard. Game CTD's before cutscene

Hi there, no matter how i try and enter the level, the game crashes to desktop with no error message once the loading screen finishes (When it should play the cutscene!)

I’ve tried : Updating Drivers, Reinstalling DLC’s, Reinstalling the entire game, replaying Galactic Core and no avail!

Really annoyed , as i am having a great time with the remakes so far, but this has disrupted my Homeworld marathon :frowning:

I’m using a relatively old system, but i’ve had no problems with FPS or loading so far. Just about to go out, so heres a quick copy - paste of speccy, if that helps.

Operating System
Windows 7 Professional 64-bit SP1
CPU
Intel Pentium G2030 @ 3.00GHz 35 °C
Ivy Bridge 22nm Technology
RAM
8.00GB Single-Channel DDR3 @ 665MHz (9-9-9-24)
Motherboard
Gigabyte Technology Co., Ltd. H61M-DS2 DVI (Intel Pentium CPU G2030 @ 3.00GHz) 28 °C
Graphics
W2242 (1680x1050@60Hz)
1024MB ATI ASUS EAH6670 Series (ASUStek Computer Inc) 42 °C
Storage
1863GB Western Digital WDC WD20EZRX-00D8PB0 ATA Device (SATA) 29 °C
Optical Drives
ATAPI iHAS124 E ATA Device
Audio
Realtek High Definition Audio

Thanks in advance, will be back to check on this thread in a few hours!

Have you tried disabling all the extra features in the option menu before loading the mission?

I’ll give that a go. Thanks!

This worked - lowering my settings to minimum allowed the cutscene to play.

Interestingly, once the mission started nothing had any textures! However, setting the graphics to their normal settings fixed this.

Thanks!