Can't complete the Slaughterstar 3000 CoS

Playing co-op with my cousin and everytime we get to round 2, wave 2 completion, the arena just sits there empty and won’t spawn the next wave for us. Might be something to look into. Seems to work fine when we do it solo.

Settings: Online Co-Op, Both on OG PS4 models, Mayhem 1 enabled.

It glitches on me in the same place and in the same way. I’m playing solo though and after 3 tries it still doesn’t complete. Frustrating since this is one of the last trophies I need for the platinum.

Just keep trying. We decided to go do all the other circles of slaughter and came back to Slaughterstar last. On that run, it finally let us go past that wave.

Has there been any word on this issue? I’m having the same problem just on round 3 end of wave 2.
Have tried multiple times on different days and still nothing.

2 Likes


For me, there is an enemy stuck in the wall that I can’t kill, which therefore isn’t allowing me to complete the wave. Very frustrating.

1 Like

This is exactly what’s happening to me. This time I can see where the enemy should be… The name and health bar even comes up, but it’s in the wall and I can’t kill it. Even homing grenades aren’t helping. I have already had to die and restart twice…
Hope this is fixed soon, it’s frustrating as.

I have this problem too. Retried God knows how many times, got frustrated and quit the game for several months. Tried again now, in January 2020, and it is still impossible to finish wave 2 of round 3, I get an enemy inside a wall that I can’t reach or kill. Really, really, should have been fixed by now I thought. :frowning:

3 Likes

Wave two and three have to be finished with rakk attack and hex grenades because of this glitch, if they actually show up on your map. Oddly enough if you deal enough damage they will run out of the wall and can be shot on the balcony.
Then we have the issue of a robot from round 5 wave 4 that occasionally spawns on the chest and you can only kill him with the above or shoot it’s hand when it attacks you(that can take a while and too much ammo) because that’s all that sticks out of the barrier.
Anyone ever completed it and had no bosses spawn? That felt like a waste of time.