Can't finish TTAODK story


#1

So I’ve played all the way through tiny Tina’s dlc on Xbox and killed the handsome sorcerer and freed butt stallion but those mission objectives just stay there checked like I did it and for some reason I can’t feed butt stallion eridium to finish the story so I can go fight the ancient dragons in UVHM I tried completely resetting story progress and still have the same issue when I get back to the same spot plz help.


(Is this thing on?) #2

Hi there!

Is there a mission marker showing on your minimap or main map at all? ISTR it not being completely obvious what you had to do to get completion on that mission, but I don’t remember the exact sequence (which is annoying as I’ve completed that exact DLC within the last month.)

If you’re on some time tonight (7-10 pm eastern) I can drop in your game and try to help figure it out.

Also, you might want to edit your profile settings as your email address is showing beside your forum name.


#3

Thanks for the response I’m not sure what the deal was but I reset the story again and I was actually able to complete it this time, I feel like it could’ve been the fact that I skipped the dragon keep area and was rocket jumping up to the teleporter to the boss fight but this time I ran up to it and everything worked fine thank you for the input though


(Is this thing on?) #4

That would absolutely do it, since it throws the game script off. As a general rule, it’s always best to avoid shortcuts involving grenade or rocket jumping when running story missions. (Another example is the WEP - if you take a shortcut to the BW enclosure, turns out you can’t get into the building…)