Can't Play Co-op - Get Disconnected

I just bought borderlands the pre-sequel and tried to play coop with my friend (who is on pc, and I’m in mac) and it didnt work… is this still an issue? cause i get no error about incompatible version…
if someone could help that would be very helpful.

1 Like

Make sure your DLC state is the same first.
If you don’t have the most recent update and DLC (which came out after this thread started) and your friend does, it won’t work.

1 Like

we’ve got the same dlc, we bought the handsome collection.
when we try to connect to each other’s game it loads and then it just bring us to the main menu.
we see each other in the party for just a brief of a second.

is there a minimum bandwidth required to play online?
because for now I play on my wifi because I don’t have a dongle to connect an ethernet cable.

1 Like

When the updated textures for PC released, they initially only released for Windows (not Mac or Linus). Aspyr was doing the update of the Mac port and I think I just saw mention that they’ve finally released the update. So make sure you have that. The other thing I’m not sure about is whether the 5th DLC was released on Mac or not - as @Jefe said, if you don’t have the same set of DLC as each other, that’s a problem. Mac sure you have “Fight for Sanctuary” as a DLC location showing up in the FT menu in your own game.

This really depends on how solid your WiFi connection is. The biggest issue is latency. If you have a solid 802.11n connection and you’re showing a decent number of bars I think you should be ok. If your computer is not in decent range of your WiFi router and the connection is dropping down to the lower frequency band, that could be an issue.

2 Likes

we are playing the pre-sequel and there is no “flight for the sanctuary” but…
in my steam (mac side) there is only three dlc installed:

  • handsome jack doppelganger pack
  • lady hammerlock the baroness pack
  • the holodome onslaught

but…
when I’m in the game launcher there are these 3 and one more:

  • calapstic voyage and the ultimate hunter…

but!..
when i am in the actual game there are these 4 and one more installed:

  • shock drop slaughter pit

so this situation is really wired i tried a lot of combinations with my friend of the dlcs, we removed all (what left me with the two that i dont see on steam since i cant remove them) and tried only few but nothing works.

note on the wifi thing, I now have an ethernet cable so I dont think the issue is about the bandwith.

I have an idea that it might be caused by the firewall on the mac, because my friend (the one on pc) is able to connect to other player’s matches, but I cant…

one extra detail that you might be familiar with: when I (again the one on the mac) try to connect to any game, I get to the loading screen and then just kicked right back to the main menu. however… when my friend (pc) is trying to connect to me he gets the message “connection lost time-out…”.

right now I am trying to install the game on my other pc (not mac but way less powerful), to see if it will work, and then the problem is isolated to the mac.

thanks for all the support I really appreciate it :slight_smile:

IMPORTANT UPDATE:
we tried both downloading borderlands 2 and connect to each other and it works!
so that leave the situation really weird because it seems its a problem only in the pre-sequel…

2 Likes

OK - moved you to the pre-sequel section to avoid further confusion!

This was originally a pre-order bonus. I’m not sure what the situation with this is on the PC side of things, but it was part of the included content in the Handsome Collection version on Console.

It seems odd that you don’t have the Claptastic Voyage showing in Steam but does show in game. The initial starting point for this is “Deck 13-1/2” - if you launch a solo game with one of your characters, is this location actually accessible in the Fast Travel menu, or is it just a bullet point location that launches the store?

TPS and BL2 were built in the exact same engine and have a lot in common, so I doubt that there’s different firewall settings between the two. You could check in your Security & Privacy preferences pane: if your Mac’s local firewall is enabled, you should see it there.