Can't See Me BA Challenge in R&D (Xbox One)

I’m trying to do the badass challenge in research and development called Can’t See Me where you’re supposed to destroy all the cameras in the area. I’ve gone through the entire area twice going to each spot where they are supposed to be but they aren’t there… but I haven’t gotten the badass rank yet either. Idk if the mission is bugged or what, but that was a waste of a couple hours since I went through the area multiple times still to no avail.

There’s a hidden one… without spoiling it outright, it’s inside, near where you first start to slug it out with the Dahl soldiers.

Where it probably is: In the trench with water in this area, if you look down at one point, there is a small opening in the wall. You have to jump down there and land in the opening (failure will mean death). There’s a camera in there. I can provide a map if that doesn’t get you there.

I had similar issue. I know where all the cameras are, cause I completed this challenge several times with different characters, but it looks like sometimes the completion will not pop-up. You can save-exit the R&D and try do this one more time.

There is another challenge for this one, btw.

There is a map for all these, which you can find in this collection:

Might want to bookmark that for future reference, as the maps have lots of useful things marked on them.

1 Like

Thanks to all for the info/advice!

@GrzesPL Ya, I will just have to do redo it at some point and see if it works then.

@VaultHunter101 Thanks for the map link. I used a map the second time I went through the area and it still didn’t give it to me even though they were all destroyed.


@Adabiviak I did get the one down there because I was trying to knock out all the challenges in R&D and going down there was one of them so that’s why I think the game just bugged and didn’t give me the achievement.

I just tried it again and it worked this time. It must have just bugged for some weird reason.

I would suggest to anyone who may come across the same issue in the future to make sure you have an active quest in the R&D area while destroying the cameras. Don’t know if it’s necessary, but it didn’t work when I didn’t have a quest in the area, but after returning with a quest to do, it worked.

1 Like