Can't steer vehicle with WASD

i see the controls in the bindings for driving show A and D as steer left/right but in game they do not. mouse seems to steer which is a pain. the guns are on turrets so i should be able to drive one direction and shoot another direction. its also a hassle to look around to find things while driving as moving the mouse to look steers me in that direction. why are the bindings not working? i tried remapping each to A and D again but it didnt help.


Hello i have same problem with vehicle stering with mouse i hate dat an all bordelands but u can turn it off in past games. My surprise comes out when i nottice i cant turn it off on borderland 3 im very sad for dat.

Hi, same problem here ! The controls seem correctly mapped in the vehicule options however, pressing the WASD keys won’t do anything.

I’ll check again all the gameplay options, just in case I missed something.

Actually, I might have found the option you need to change in order to be able to use the free view with the mouse and the WASD keys only for steering/accelerate.
That’s in the Gamepad options (even if you don’t have any connected to your machine), I changed the following two (see capture).
As the game is in French on my PC I don’t know the exact translation, but it basically says
“buttons configuration - vehicule left”
“analog sticks config - left handed”

As a result, the mouse no longer controls the steering.
You might want to give it a go


that did it. the english equivalent of the setting is Driving Button Scheme and changing it to Vehicle Relative: Left Side. i did not need to mess with the second setting. its still set at default but i can now drive with WASD and freelook/aim with the mouse. thanks. never wouldve thought that the controller settings would impact mouse/kb.

it worked…but the W/S doesnt work anymore…LOL, even if i rebind the key xD

you changed the setting i listed above or shown in the screenshot? worked for me. WS goes forward back just like it used to and now AD steers. maybe reset all your bindings to default and resetup making sure to make the above controller change?

Yeah well i reset everything anyway, rebind everyshit…I created a ticket for it, but i will probably play whit the mouse then i guess xD

When I changed my driving controls to ESDF I noticed it would take away my travel key when inside vehicles was wondering if anyone else got the same issue

1 Like

Yeah same here. Change it to vehicle relative: left side. But being a southpaw, I cannot map my keypad to it so have to use WASD for driving and switch to keypad when on foot.

Think somebody should be looking at it to have the same bindings available.

Did you try changing the second setting to “Southpaw”?

Did that. Southpaw is only if you are using a controller. But even with that setting, it still keypad and mouse look. ARGH! Skag it!

Hiya, easy to fix for PC users with a keyboard and mouse. Click Esc, options, controls, choose controller image (even though you aren’t using one), on ‘driver button schemes’ select ‘vehicle relstive: stick only’ and that’s all you need to change.

1 Like

Hi, still after applying this trick (vehicule left+left handed) and remapping the keys wsad in keyboard settings, I cant use W to go forward, the rest (S.A.D) is ok. Very frustrating, this is a STOP for me, I cant play anymore this game that I started to love… since I hate using the mouse or the pad to drive :frowning:
Such a shame for such a AAA !!!
ps: excuse my french ^^

Thank you for this, seems like a mistake, why should you have to go into controller controls to change something for keyboard/mouse, but it works!

My “forward” and “reverse” buttons didn’t work for me neither when i change my Driving Button Scheme to any of the above resorted awnsers.
I changed mine to “Camera Relative: 3rd person” and no changes to “Driving Thumbstick Scheme”

+To add i have a “AZERTY” keyboard

ESDF doesn’t work for this game because it doesn’t let you rebind T or Y or menu options.

1 Like

I want to steer with ESDF. Please fix it Gamebox.

I submitted a ticket 2K Support

huh, the support guy!