Claptastic Voyage Purchased Not Downloaded (Mac)

Wondering if other Mac users have encountered this problem.
It shows that the new DLC has been purchased but not downloaded.
I tried the usual remedies but nothing has worked thus far.

In other instances, the DLC’s would show up within the same day.
But in the case of the Tales of the Borderlands it took over 7 days for it to appear.

Also, this was part of the Season Pass.

I am on the PC using Steam and I am getting the same messages as you

I have had exactly the same problem and have tried to get a responce from gearbox but haven’t had anything yet, It’s not the first time but this dlc actually looks good and I really want to play it.

This happened a few times in BL2 for me as well - esp the headhunter packs.
What is going to rock is when we are thanked for our patience
with a few golden keys for legendaries. :sunglasses:

Still nothing on this matter??

It’s been almost 2 months since this topic was posted and I still haven’t been able to access the Claptastic Voyage DLC for Borderlands TPS on my Mac. I have the season pass, but while Steam says I have access to it, the game itself says that I don’t have it installed. I just want to play the DLC :frowning: