Classic Homeworld modding, mods not working/not allowed? (solved)

Hello,

I’ve made some changes to Homeworld Classic’s singleplayer.script file and put it in the Homeworld1Classic folder. In previous Homeworld versions the changed file would be automatically read. But not in Gearbox’ version.

I’d like to have some feedback about why this is. Aren’t people allowed to mod classic Homeworld?
If so, why is this?
If not, what am I doing wrong? I am doing the same things I did over a decade ago.

1 Like

It looks like this is a bug due to some code that changed when we removed the dependency on the CD-ROM check.

It looks like the only work around for this would be to extract out the loose files from the .big file in the Data folder and run with the loose files (you may need the /ignoreBigfiles commandline argument).

Currently, for external files the game looks in Homeworld1Classic\exe folder, not in Homeworld1Classic\Data.

/ignoreBigfiles isn’t a usable parameter for Homeworld 1 classic. (It ends up showing the window with all allowable parameters.)
I was already using loose files by the way, just like last time.

It seems p2ambassador is right. The game looks for files in the exe folder, not data or root.

Unfortunately now the game refuses to start and gives me crash logs when I leave a modded file inside the exe folder. These crash logs are not generated in readable text (except for a few lines).

I hope a dev can take a look at this. :confounded:

For the record, as a test I extracted singleplayer.script from Gearbox’ classic Homeworld.big file and modified the starting RU as a test.
Shouldn’t be something crash-worthy.

I also tried changing unit caps in unitlimitcaps.script. Same problem.

Edit: One of the crash logs:
http://avatar.home.xs4all.nl/crap/homeworld_1015476_crash_2015_3_9T19_11_39C0.mdmp

I took a quick look at this and here is what I’ve discovered. I had already suspected the issue was that the original game relied on the environment variable “HW_Data” being set to the path of the game data directory. When the game launches it pre-scans the directory HW_Data references to see if any loose files in it are newer than the Homeworld.big file and then keeps track of which files are newer. We veered away from relying on environment variables so we do not set this as part of our install. If it’s not set then the directory it scans is the current working directory, which is the exe directory from which the game runs.

I’m not entirely sure why the game crashes for you. I’ve copied singleplayer.script into my exe directory and changed the starting RU’s with no crash issues. I’ve checked in a fix for this that should appear in the next patch, but in the meantime I think that setting the environment variable “HW_Data” to your data directory should fix the issue.

1 Like

Strange that you don’t experience crashes. Even an unmodified singleplayer.script provides crashes for me.
Thanks a whole lot for looking into it! I’ll patiently await the next patch then. :smile:

And 10 years ago some guys made simple no cd crack… :smiley:

I noticed your latest patch solved the problem!
Thanks, Gearbox. :relaxed: