"Commander Lilith & The Battle For Sanctuary" DLC not working (despite downloaded and installed)

This issue is regarding the new DLC “Commander Lilith & The Battle For Sanctuary” on PC.

I used to play Borderlands 2 on Steam through my friend’s shared library. I understand that there will be issues playing DLCs if the Steam game you are running is a shared game that belongs in another person’s library. Since the new free DLC “Commander Lilith & The Battle For Sanctuary” was released and the game bundle was also on massive discount on Steam, I decided to purchase “Borderlands: The Handsome Collection”. Now that I owned the base (with all other past DLCs included in my purchase), I should be able to play the new DLC without any problems.

However even after installation, the new DLC fails to launch when I try to access it in-game. In the fast travel menu, it shows a location " *Fight for Sanctuary" with an asterisk but i cannot fast travel to that location. A message appears every time: “You can not travel to Fight for Sanctuary because you do not own it. Download it today!” and Steam launches the Commander Lilith DLC store page prompting me to download it. No matter how many times I’ve downloaded and reinstalled the DLC, I kept getting the same message in-game when I try to start the DLC.

I am not sure what is the issue. In my Steam library, it was shown that I have the DLC in my library which means i already own the DLC. I have uninstalled the base game and the DLC and reinstalled them over and over again but the issue still persists. No matter what I do, I still cannot get the DLC to start in-game. I can’t seem to know what is the cause for this problem as I believe it should not have happened in the first place.

dlc%20is%20already%20in%20steam%20library%202 dlc%20owned%20and%20installed%202

Has the DLC definitely installed completely? I know when it released I had an issue where I thought it had installed but it was taking its sweet time with Steam.

It may also be worth installing it, closing the entire steam client and then seeing if that helps.


If neither of these are the case would you mind sending a support ticket into the helpdesk with as many details as possible to, hopefully, allow Gearbox to figure out what is causing these issues for the playerbase, and give you a solution while they’re at it.

https://gearboxsoftware.zendesk.com/home

I already did all of what you’ve mentioned but still no luck. And yes, I took a bunch of screenshots that proved the DLC is already installed but the main game somehow doesn’t seem to know this. The game kept prompting me to download the DLC at the Steam store page even when it is already installed.

If you’ve tried the Gearbox support and that yields no results it may also be worth hitting up the steam support too. They may know of some issue that the if affecting it, or another forum user may.


I hope you get this sorted, preferably sooner rather than later.

I’m assuming that when you described reinstalling the DLC multiple times in an earlier post, it was from the in-game prompt -> Steam store route. If not, it would be worth trying that - someone solved a similar issue on PS4 the same way.

Otherwise, does Steam have some way of rebuilding it’s database? It looks like the licence information on the DLC is “stuck” from when you first downloaded it. If that’s the case then as Tokesy suggested, perhaps Steam support might be a better place to ask.

Thanks guys, I have submitted a request to Steam support. Shall wait for response. In the meantime I will see if there are other methods I have not yet tried, hopefully I come across one that would help resolve this issue.