Compatibility Pack Nightmares


(Zoë) #1

I turned on my 360 to try out the new DLC and, despite getting a 5MB update, couldn’t select the Baroness as a new character. After turning the game on and off several times and trying unsuccessfully to download the character from the DLC menu (the one you access from the main menu) a new downloadable content option appeared: a 376 MB compatibility pack. After downloading the pack from the DLC menu, the main menu then added an option to download a compatibility pack - the same one I just finished downloading.

I turned the game off and on once more, and when I got to the main menu, I got a popup box telling me I needed to download a compatibility pack, the first time that’s happened since the Holodome DLC released. Turns out it was the same pack that I downloaded after it finally showed up on the DLC menu. After trying to satisfy the game by downloading it AGAIN, it took me to the main menu where the option to download the pack persisted. The DLC menu also told me that the pack was available for download but not installed on my system.

A little perturbed, I went on to my hard drive and deleted the pack to see if the situation would resolve itself through a normal download after I turned the game back on. Back on the game’s main menu, there was no option to download the pack except from the DLC menu. I fully downloaded it from there and, like before, the game then started to tell me that I needed to install the compatibility pack both from a popup box, and from the now-present “Compatibility Pack” menu option on the main menu.

This was probably foolish of me, but I then deleted ALL three compatibility packs on my hard drive (the one from Jack, one from Holodome, and one from today) just to see if the issue would resolve. That only made things worse.

Now, the game keeps telling me I need to install either the 187 MB pack from the Jack DLC, or the 376 MB pack from today. Despite re-downloading them, the game won’t register that they’re on my hard drive. As for the Holodome pack, it’s never asking me to download it.

I’m now stuck in this endless loop of a compatibility pack nightmare and nothing I try is resolving the issue. The game flat-out denies that I have any packs on my system.

Any help would be greatly appreciated!

(Oh, and for the record, I have the season pass and that’s why I thought the new character DLC would download without fuss).


EDIT - I’m also noticing that the Baroness DLC isn’t on my hard drive and I’m never given an option to download it. What’s going on here? :confused:


EDIT #2 -

I deleted both packs again as well as clearing my system cache (a fix that worked for the compatibility pack issue in BL2). Again, no dice. The game won’t register that I have the packs even after I downloaded them and confirmed that they’re on the hard drive by viewing the drive’s contents (the in-game status of the new pack is still “Not Downloaded”). The DLC menu finally gave me the option to download Aurelia, but the download I got from the Xbox store was only 108 KB. The game tells me that Aurelia is installed, but that I haven’t purchased it. My hard drive still doesn’t say that Aurelia has been installed. I have two compatibility packs, Jack DLC, and the Holodome DLC, but no Aurelia.


(Influencer Guy) #2

Hey @TenFootBunny,

Sorry to hear about your issues here! I I don’t think I saw anywhere above where you had cleared your cache. If you haven’t yet, that should get you going. In case you’re not familiar with that process, here’s a little info that might be helpful:

http://support.xbox.com/en-US/xbox-360/system/clear-system-cache

Also, for reference, here’s our Zendesk link addressing the compat pack loop:

Hope this fixes it for you. If it doesn’t or you have any questions, please don’t hesitate to ping me!


(Zoë) #3

Thanks for replying to this in both forums… I bet you all can’t wait until there’s only ONE official forum again, eh? :smile:

I did all the steps again, but the loop is still there. After once again deleting the two packs and the cache, the game redownloaded the title update and now only prompts me to download the newest compat pack (unlike before where it kept wanting me to download today’s pack AND the one from the Jack DLC). I then downloaded today’s pack from the in-game prompt, and when that didn’t work, I deleted the pack and downloaded it from my account history while outside the game. As soon as I got to the main menu, I was still prompted to download today’s pack even though it’s clearly on my hard drive. The DLC menu still shows today’s pack as purchased, but not downloaded.

One person in another thread on the old forum stated that Aurelia is now playable, but can’t go online due to the persistence of the compat pack loop. I can’t verify the online portion of their claim because none of my friends are online yet, but, like that other poster, I CAN play Aurelia now.

Thanks to you and the rest of the team for your ongoing work to fix this problem! :thumbsup:

(On a side note, Aurelia’s outfits are the best of them all. Wow!)


(Djdrago) #4

Hey man know if this helps at all but i just had me and a friend rent the game from redbox tonight 1/27/2015 ive played it before he has never so upon starting the game it asked to download the comp pack that is 300 something mbs so i did the install in game but when it finishes it askes to go back to the title screen and just reloops cant connect to find games or anything ive downloaded all the comp packs from outside the dashboard and deleted the packs and cleared my system cache rebooted nothing it still gives me this loop hmm hope there is a fix what a waste of a free game code :frowning:


(Djdrago) #5

ive tried doing my research but i only come up with loose ends and borderlands 2 issues i tried those but nothing also
EDIT 1
What if im not able to use a usb will it still work ?? i’ve deleted the game and everything from storage and cleared my system cach but why is it it doing this in the first place ?? i remember a couple months ago the game worked just fine for me
Edit 2 : so this morning 1/28/205 i cleared my system cach restarted the xbox put the game in and downloaded the pack it asked me to return to the title screen i hit no i went back out to the game title screen and hit start again and loaded back in and it works fine for me now!


(Seanmike) #6

Hey @joekgbx I’ve followed those directions as well, and I’m stuck in the loop. Here’s what I posted elsewhere (and it’s not just me, but also my friends):

So, my usual group of Tuesday night BPS friends and I are all having the same issue - every time we log in, it wants us to re-download the compatibility pack.

I’ve deleted all the old ones and re-downloaded, I’ve cleared the system cache a half dozen times…nothing seems to work.


(engineer, gemini, geek) #7

Having the same issue. I following the loop instructions but it was not resolved.

H


(engineer, gemini, geek) #9

Saw this on the original formums and tried it. Seemed to work for me.
http://forums.gearboxsoftware.com/showpost.php?p=5193047&postcount=6

Here is my post with some small adjustments to the method for cleanliness
http://forums.gearboxsoftware.com/showpost.php?p=5193150&postcount=7

H


Anyone else having Compatibility Pack issues?
(Influencer Guy) #10

Ok, thanks for keeping me updated guys. We’re looking into the issues of course. I’ll let guys know of any breaking developments and in the mean time, keep trying and let me know if things get worked out on your ends.

Thanks for your collective patience too. You guys are RAD.


(Justincausey46) #11

Figured out how to fix compatibility pack issue… Most of you are running multiple hard drives including flash drives. If you are stuck in the loop put the pack on your hard drive then copy (not move) the same file to your flash drive and it will fix the loop issue.


(Zoë) #12

Seems the hotfix that went out today solved it all. I went and did other things last night after none of the prescribed fixes worked, and when I loaded up the game today, it didn’t ask me to install any packs. Every item in the DLC menu is listed as purchased and installed. I can even open up online play without a hitch.

Methinks this baby has been put to bed. :smiley: Thanks to the team for all your work fixing the issue!


(Djdrago) #13

yeah should be fixed btw nothing i tried yesterday worked at all and i dont use nor have a usb drive . Thanks Team@!


(Armback) #14

You asked me to reply here.
I cleared the system cache on my x360. Now the download page shows that I have purchased Lady Hammerlock. But the character does not show up when I try to pick a new character, Only the four original and Jack is in the list.


(Influencer Guy) #15

Ok- thanks! Seems like a bit of an anomaly. Most people are up and going. Try this: go to gearboxsoftware.zendesk.com and submit a support ticket. That will allow the support team to get some more info/documentation on the issue. They’ll get you fixed up as soon as humanly possible.