Designer's cut issue: extracting weapon doesn't work

Hello!
I’ve completed the challenge and put 3 white shields and 2 legendary weapons in the extractor.
In the bank, that shows me I had 309 slots taken.
After extraction, I looked in from the extractor: 314 slots taken in the bank.
So I went to Sanctuary and… 309/400 slots taken. The 3 white shields and the 2 legendary weapons are missing…

I assume you’re talking about arm’s race: is it possible you didn’t complete the extraction after putting into the extractor–you do have to scroll to the bottom and hit the extract button. I actually forgot to do that once.

I didn’t forget, because I always go into the extractor twice to verifiy if the number in the bank is still the same.
A mate had same problem than me.
Strangely, both of us had the problem solved with the 3rd extraction.
And the problem occured only with the boss extractor, the one with 5 items.
In my case, I used the station to travel to sanctuary the third time and continue to do that, in case than using the Echo menu is the source of the problem.