Digi-Clone changing weapons when swapping places

Has anyone noticed the Digi-Clone changing weapons when you swap places with it ?
I couldn’t find a topic on this already posted, not sure if this is the best place for it but I thought I’d ask the question here first.
Example: I wanted the clone to use a shock Westergun that I had equipped in slot 1. I could have sworn that I had it equipped when I summoned the clone but, halfway through the fight, after I had switched to my NoPewPew, the clone started using that gun.
I initially thought I’d had the wrong weapon equipped at first so I payed close attention to which weapon I had equipped when I summoned the clone and, sure enough, after I have swapped places with it, the clone had the NoPewPew.
I’m not sure how long this has been a thing, certainly I haven’t played Zane clone as much as I have the other vault hunters but I didn’t notice it until recently. It only happens rarely, I noticed it most playing DLC2.
Has anyone else seen this ?

Yeah the clone randomly gets resummoned sometimes, I noticed it the last time during the initial fight at the guardian takedown. Kinds weird. At first I though it would be after a certain duration, but I can’t reproduce it at will.

1 Like

OK, so maybe the clone is dying and getting re-summoned then ? (without pushing the summon button)
That would make sense as, most of the time, swapping places keeps the gun I summed it with.
It’s a really rare thing but I’m glad to see I’m not the only one who has seen it happen.

Maybe hard to tell mid fight but after the initial summoning is it possible that when you have swapped, you were holding a different weapon?

Would make sense to me that the clone would match the weapon held when summoning and when swapping as it is essentially being refreshed.

1 Like

I had that happen a few times yesterday, he was summoned with an OPQ and then I switched to a cryo Anarchy and then I switched places with him and suddenly we’re both using Anarchies.

1 Like

Yes sometimes the clone does that. for some reason when you press the swap button the game will register that the terrain is not “suitable” for the clone (maybe cuz an enemy is standing there or something affecting that area) but when that happens, the clone takes a little while to appear (like 1 or 2 seconds) and when he appears it has the gun that you currently have equipped.

I noticed some times during boss fights. My clone ended up under the boss when it entered one of its invulnerability stages, I tried to swap places (we dindt swap and it took a couple of seconds but the clone appeared in front of me and had changed guns.)

I know that the skill had a lot of time left cuz I run Seein’ Dead and the AS meter was almost full.

I have tested the clone for my tier list about 20 hours in the last three days, tested about 200 guns already, played with them and of course swapped places alot.

I have not once seen this issue occur for me.