DLC Not Downloading via Steam

I am currently trying to download the new Commander Lilith DLC but Steam won’t download it.
I have tried:
-Unchecking and rechecking the install box.
-Verifying the game cache
-Deleting the DLC Folder from the game to reverify the cache to force it to redownload all the DLC.
-Redownloaded the game as a whole.
-Played with my Steam Download settings, switching the download area to other areas and so on.

I can’t manage to get the DLC to download no matter what I do, has anyone else had this?

2 Likes

Same here, when ever I try to click on the download it just opens the game instead w/o the downloaded DLC.

MacBook Air 2015

Exactly the same issue here…

same problem. Seems like the download is not getting queued, I hope its not some glitch that charges me 15.00…

If the launcher launches, close it and the download should continue. At least it did for me. If you’ve altered the start-up settings to -nolauncher, remove that line and try again.

Not working, closing out the launcher isn’t doing anything.
I have no clue what you mean by the -nolauncher thing.

It’s a way of making the game start directly without starting the launcher first. I’ll assume this isn’t an issue since this is new to you.

That’s all I have. Submit a support ticket?
https://gearboxsoftware.zendesk.com/home

Might be worth trying to restart the steam client as well if you haven’t, I’ve had it break on me before and think it’s already doing something that it’s not.

This is a glitch that has to do with shared content (at least in my case). I tried downloading this on my 2nd account (which I use all the time now) and it wouldn’t trigger the download despite owning it on my first account that was linked together.

When I logged into my first account that owns the game it did the same thing, it launched the launcher, but noticed after closing the launcher it started a 2.9gb download that was the DLC. I just started playing on my first account because my main characters are on there anyways I just forgot. Apparently its impossible to get the DLC on a shared account, but I think all my other DLC transferred over to my second account, weird.

2 Likes

It is a shared account issue. The DLC won’t properly install or rather run on a shared account. I have yet to find a way to circumvent this problem. Anyone have an idea?

File a support ticket and ask if this is expected behaviour?

I’m experiencing the exact same problem too. Cant get it to work no matter what I’ve tried, and I 'm sure I pretty much tries everything there is already. Hope someone can find a solution to this issue.

See post 9 in this thread. It also appears that whatever in the DLC licence is causing this problem can linger. Might want to keep an eye on that thread or contact Steam support yourself in addition to filing a support ticket with GBX/2K.

1 Like

I have already sent a support ticket to both 2K and Steam. Hopefully 1 of them can help me resolve this problem soon as it is starting to drive me crazy. Tried everything and still no luck getting it to work. Gave up and had to leave it to 2K/Steam to do something but who knows how long that could take. So I hope maybe someone who’ve found a working solution would be kind enough to share with us.

EDIT: I have also created a post on Steam discussion seeking help on this issue. So far nobody knows of a possible solution to this yet.

Steam discussion link:

2 Likes

i also can’t start tis on steam. i try to go the the fast travel to start it and it brings up the steam store asking me to download it and i click i ton download and it says i’ve already downloaded it

There seems to be an issue with the DLC not working if game sharing between accounts is involved. Does that apply to your situation?

not that i remember? i may have shared the game with an alt account years ago but i have no idea hows to verify that. i’ve drank a whole lot since then

IIRC the DLC should download with the primary account. If your current account is actually the secondary, that might explain the issue. Going to ping @Tokesy97 since he uses Steam and might have a better idea on how to check this situation.

I’ve never played with the shared account function on steam.

I know when it first launched I had a few issues but that was more not giving it time to fully download and install.


Try rebooting steam? If that doesn’t work try verifying files. If that doesn’t work try a full reinstall.

Beyond that I’m not sure what the issue may be.

So I had the same issue with both HD texture and the DLC for Lillith. Went into downloads. Says nothing is downloading, auto-update enabled. So I just hit pause then resume and it immediately started downloading. I hope this helps

1 Like