DLC still disabled after purchase

Hello. I’m having these issues on the Epic Games store when purchasing Risk of Rain 2. I bought the [base game + DLC] bundle, but the DLC is still disabled in-game no matter what I do.

I tripled checked that the EGS recognizes the DLC in my library, but the game still doesn’t. Even tried reinstalling and nothing.


Been dealing with this for days now and nobody seems to know of a solution. I have encountered other people having the same issues but they also can’t find a solution.

Does anybody know how to fix this?? Any help would be appreciated.

Thanks!

It’s in your library, but is it actually installed and activated on your system? I’ve seen similar issues with BL3/Epic where the user had to do an additional step within their library before launching the game to get it to work.

As far as I know. Some games’ DLC have to be activated through the EGS via the “Manage DLCs” option in the library (after clicking the game menu icon). But other games like this one manage their DLCs in-game, meaning the DLC content is already included in the base game (no need to download additional files after purchasing the DLC) and the game simply unlocks the DLC after you purchase it.

That is to say that I don’t think there’s anything I can manually do via the store to fix this, but if you know anything that may help please let me know. Thanks!

Sorry - not familiar with TTW. I’d just assumed it was the same as BL3. You’re best bet is probably to contact 2K support.

Im having the same problem, and Im still hoping for a reply from Epic, Gearbox or 2K, after submitting my ticket. I just wanna play what I paid for.

They still haven’t responded to me after 3 days, and from what I’ve from others they’ve actually answered they just tell them to contact the devs, who then in turn tell us to contact GearBox. So yeah…

A post was merged into an existing topic: About the Bad Posts category

Having the same issue as well. I have gotten a response from Epic, that is to contact Gearbox support.

GBX support link:

https://support.gearboxsoftware.com/hc/en-us/requests/new

RoR2 should be listed in the drop down menu.

IIRC GBX is the publisher while Hopoo Games is the developer.