Drop kick bugged?

Is drop kick bugged? The text States that when you are sprinting his secondary attack is a drop kick but when I do sprint and hit my secondary attack he just keeps doing the clap…thinking it might be controller issue I tried 3 different controllers with the same result so I’m not sure if I am just an idiot or there is an actual issue with the attack…can anyone else confirm this?

You have to use the melee button not his secondary attack.

Nope no dice he just goes into his regular melee

The melee button as in B or circle on a controller, not sure what it is on PC.

Then I might just have a odd buggy install cause I am hitting be or my key bindings are all jacked I’ll take a look ty for quick reply

Does Melka’s slide kick work for you? (The same thing - melee while sprinting) If that works but El Dragon doesn’t, then there’s likely a bug with the latter rather than your controls.

I’m getting the same issue on the PC. Then again I only played him in one mission, so I may not have been doing it right.

The “quick-melee” button… you know the universal melee button that works for every character.
The one with the knockback effect.

Not your primary attack button.
Not your secondary attack button.
The third one.

2 Likes

Ah. Thanks for the info.

Mouse button 3.