Enhanced Edition: Gameworld not rendered at all

(Gamer24) #1

Hi there,
so like many i just installed the Enhanced GOTY of BL1. Sadly, when i launched the game it told me
“Warning: Your System does noot meet the minimum system requirements. Your game experience may suffer. Please go to support.2k.com to see the complete list of System Requirements for this title, as well as other Frequently Asked Questions.”
Odd because I do have a i7 6th gen CPU, 16GB of RAM and a OC 1070, so naturally i highly doubt this to be the case.
When i go into the settings, it seems to recognize my GPU just fine.
When i launched the game, everything seemed okay at first glance. Menues, Options, all there… but… not the game world. I booted up a new char and all Cutscenes played fine, but as soon as i leave the bus? No gameworld. The HUD however gets rendered fine. I can move, I can shoot, but i dont see anything at all.
Considering i’ve seen people run this with a worse setup, I highly doubt that this has anything to do with my setup not being good enough, but rather it being a very very very annoying bug.
If anyone else is experiencing this issue, or has any suggestions I’d be grateful for the input.
Btw, as far as I could see no System Requirements are currently to be found on the 2k Support site.

Edit: So by looking around, i’ve found several Log Files - each with some “interesting” entries. Still nothing that seems to be the immediate culprit.
Also: I’ve checked all game files for validity in steam and for some reason 29 Files failed that check. I’ve redownloaded them, but the issue is still the same.

(kills Craw with Knoxx's Gold) #2

Long shot - one of the old .ini files had a setting called UseTextureStreaming (or something similar). If this was set to false, you would get no world rendering.

(Gamer24) #3

Sadly no changes.
I think one possible problem might be this line in the Logfile:

2019.04.04 10:28:06.672 +02:00: 000055: FindGraphicsCardPreset() BEGIN ------------------------------------------------------
2019.04.04 10:28:06.753 +02:00: 000056: GetOperatingSystemVersion(): Version=10.0.17134, architecture=64-Bit, majorVersion=10, minorVersion=0, build=17134, is64BitOS=False
2019.04.04 10:28:06.753 +02:00: 000057: 1. OS Version: Major=10, Minor=0, Build=17134, Is64BitOS=False, sFullOSVersion=10.0.17134

2019.04.04 10:28:06.753 +02:00: 000058: 1. The minimum supported OS is Windows 7 64-bit.
2019.04.04 10:28:06.753 +02:00: 000059: FindGraphicsCardPreset() END (FAILURE) ----------------------------------------------

Which is really weird, since i run a normal Win 10 64 Bit professional.

(Paul Sorba) #4

I have the same issue.
I’m on W10 64b pro, with all the latest updates and drivers.

GPU is an Nvidia 1070ti Founder’s Edition.

(Gamer24) #5

sorry to hear that you’re having the same issue - allthough i’m quite glad i’m not the only one having this issue. Shortly after i created this topic, i’ve also involved the 2k support, but nothing from them so far. If anything changes, i’ll update here asap

1 Like
(Paul Sorba) #6

It’s always nice to see that you are not alone.

For what I gathered, the support team is crawling under bug-reports and, unfortunately, ours seems to be quite rare (3 people that I know of… and I asked Reddit), I don’t think it will be their priority, which is understandable.

Thanks for the update.

(How much time do we have?) #7

That is indeed odd. Are you still getting multiple files flagged when you do a steam validation? Also wondering what would happen if you set the game to run in Windows 7 compatibility mode?

(Paul Sorba) #8

No missing or corrupted files and a copy of the folder runs fine on my laptop (W10 family though), so generation compatibility is unlikely… I’ll try it though.

I’ll investigate further with VMs, but it will take some time.

(How much time do we have?) #9

That logfile entry: any idea if the FindGraphicsCardPreset is part of the game code, or something within a graphics card driver? If the latter then maybe manually updating the driver might be in order?

(Paul Sorba) #10

Already tried, it didn’t resolve our issue.
I think that relates to the failure to properly detect hardware, which seems not to be related because the same error occurred on my working system.

PS: Compatibility didn’t resolve the problem.

(kezfx) #11

I’m also having the same problem. Although I didn’t get a Warning message, but everything else is the same. UI and pre-rendered cutscenes, and audio work fine. Just the “gameworld” doesn’t load at all.

I’ve already emailed support last week, calling it “Black screen with UI” I didn’t know to call it “Gameworld not rendered.” Your title is more descriptive (thanks!)

Here are my specs as well for an FYI:

OS: Windows10 Pro
CPU: Intel® Core™ i7-5820K CPU @ 3.30GHz
RAM: 32 GB
GPU: NVIDIA GeForce GTX TITAN X 12GB

I hope there is a patch soon, I was lookin’ forward to checking out the awesome updates in the game. :slight_smile:

(Gamer24) #12

okay, so i wonder if its a coincidence that all of us are running W10 pro though.
I’ve heard back from the support yesterday night, having received the basic troubleshooting stuff like updating drivers etc. i’ll go through them probably tomorrow after work and see if something from that list actually works. Otherwise they’ve asked me for DxDiag and MSinfo files to further investigate, so maybe people who write to the support can check those files as well.

Update: I’ve gone through the steps suggested by 2k Support, and as expected, none of them did help. So i’ve created the MSInfo and DxDiag Files for them and had them attached to the support ticket. If anything comes from that, i’ll update this thread again.

(Paul Sorba) #13

Huzzah !!

I finally got it working.
All I had to do, probably from right after updating my drivers the first time, is to remove the Borderlands GOTY directory from inside my documents. (URL below), and restart the game :wink:

C:\Users\{username}\Documents\My Games\Borderlands Game of the Year

(Gamer24) #14

OMG! That works!!! Really nice find!

(Paul Sorba) #15

You can thank Slackers Undercover, on Youtube, he was the one who suggested it to me :smile: