[FIXED] I can't fast travel after update

Hey y’all. I just bought the Ultimate edition and have been enjoying BL3 so far tho I experience crash once or twice when I play.

Anyway, after the update yesterday I can’t fast travel anymore. I always use the d-pad to select way points and then fast travel there.

I tried looking up a lot of videos and posts regarding this issue, but none worked. I even deleted the game and re-installed it but the problem still persists. I’m still stuck in one place. I did already sent a ticket, but I hope the devs sees this and fix this asap. : (

Update: It’s not really fixed, but I found a temporary fix for those who are still stuck in one place, and can’t fast travel anywhere.

Go to Settings > System > Enable “Use (X) Button for Enter”. It worked for me! Happy gaming :slight_smile:


I have the same problem and 2 of my friends are the same


Experiencing the same Bug, I can’t fast travel anywhere after the latest patch(06/24/21). Please fix GEARBOX


I am having the same problem. Can’t fast travel anywhere after the recent patch.

Also submitted a ticket


i am having the same problem here, play on ps4 pro now all my character get stuck in therer location


also have the same problem, stuck on a world i don’t need to be on. tried switching characters, tried toggling the events on/off. nothing works. the circle fills but the transport doesn’t happen. (ps4) (also submitted a ticket)


Im also having the same problem, im on PS4 and badly want to max level all of my vault hunters to start farming


I hope they’ll see our tickets and fix it asap. This is really annoying…


same man anybody find a fix yet??


Character cannot be deleted and fast travel is not possible
Delete key is not assigned When will the fix be released?


SAME HERE!!! like seriously. Using Ps4 and am located in Asia. Tried even reinstalling and using other characters and nada… doesnt work.


It seems like a common issue in ps4 only since I’ve also seen people from reddit & discord complaining.

Dang it Gearbox🥲

So many gamer has SAME Bug!!!
i trouble same thing.(South Korea)

PLZ fix The BUG!!!


looks like an asia thing… is your news box moving? i think its the server… though i fail to see how the server can affect the game… i tried playing offline and it still do not work

After the latest update, i can’t fast travel anywhere, press circle but nothing happen

video version: https://youtu.be/ow_GrjIoYoo

Already try to reinstall, reopen the game, relog nothing fix it, try with different controller, account, characters

So happy about the new patch but I can’t play at all, I’m stuck at Promethea forever,

1 Like

there is another thread on this and most are stuck as well… are you in asia… so far only asia plays seem stuck… im in Singapore

1 Like

I’m from the Philippines. Not sure if its an asia thing? I really hope this gets fix within this week.

Oh btw, I saw some people switch their buttons and it worked for them. They changed ‘O’ to ‘X’ in the ps4 settings. I tried it no luck tho. Might work for some.

OMG I FOUND A TEMPORARY FIX!!! Don’t switch the buttons in the accessibility tab.

Go to Settings > System > Enable “Use (X) Button for Enter” and it now works!!!

Thanks for sharing! The fix seems to have worked for me.

But i still do want gearbox to sort out this isssue.

And not too sure if it’s relating to the region. But yeah, I’m a Ps4 user from Malaysia.

1 Like

Of course, I want an official fix too. They still haven’t replied to my ticket so this temporary fix is better than nothing.