[Fixed ]No sound in-game

I played Borderlands 2 last year and uninstalled. I installed it today again, and after downloading, usually a setup or 2 runs afaik, but it didn’t happen when I installed this time. It worked perfectly last year.

When I verify the integrity on steam, it shows 1 file is missing and will be fixed, but the sound doesn’t work even after that.

I’ve tried:

  1. Uninstalling and re-installing.
  2. Uninstalling sound drivers and reinstalling (Realtek HD Audio and Intel Display Audio using Driver Booster and getting the drivers from Realtek site).
  3. Going into Settings > Sound > App volume and device preferences > selecting “Speakers (Realtek High Definition Audio)”.
  4. Checking if the volume is low in the Volume Mixer.
  5. Running as Administrator, but the game keeps asking me to Run as Admin and doesn’t even open. Same for running in XP SP2.
  6. Tried using -nolauncher in launch options for steam.

Can anyone please tell if how to fix this? Thanks in advance.

I found the fix in case anyone would want it later.

If you have an MSI Laptop like me, Nahimic 2 Audio manager conflicts with BL2, so you should right-click and quit the app from the notification area near the clock. Then run BL2, it will run with audio. This will work if you have Nahimic, atleast it worked for me.

1 Like

Hey I found the issue. If it’s not the Nahimic 2 Audio problem, which it wasn’t for me. I ran task manager and then ran the game and closed everything unnecessary (ie. webpages, etc) to make sure I could see if any new process cropped up that wasn’t Borderlands, and I found the issue.

For some reason Windows Movies & TV opened as the game opened and was preventing sound from playing, I closed it with Task Manager and the sound instantly cut on.

I am going to investigate why it opened up to begin with, I’ll reply if I find something that can be fixed by us, otherwise I will leave it to Gearbox.

That is odd. Is it set as the default app for certain file types? I mean, it shouldn’t be triggering when the game plays a cut-scene or intro video, but maybe there’s some weird interaction with the launcher as well?